aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flex
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/flex
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/flex')
-rw-r--r--recipes/flex/files/fix-gen.patch17
-rw-r--r--recipes/flex/files/flex-lvalue.diff36
-rw-r--r--recipes/flex/flex-2.5.31/include.patch27
-rw-r--r--recipes/flex/flex-native_2.5.31.bb10
-rw-r--r--recipes/flex/flex.inc11
-rw-r--r--recipes/flex/flex_2.5.31.bb9
6 files changed, 110 insertions, 0 deletions
diff --git a/recipes/flex/files/fix-gen.patch b/recipes/flex/files/fix-gen.patch
new file mode 100644
index 0000000000..55f4f6fdf5
--- /dev/null
+++ b/recipes/flex/files/fix-gen.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- flex-2.5.31/gen.c~fix-gen
++++ flex-2.5.31/gen.c
+@@ -1812,8 +1812,7 @@
+ if (yytext_is_array) {
+ if (!reentrant){
+ indent_puts ("static int yy_more_offset = 0;");
+- }else{
+- indent_puts ("static int yy_prev_more_offset = 0;");
++ indent_puts ("static int yy_prev_more_offset = 0;");
+ }
+ }
+ else if (!reentrant) {
diff --git a/recipes/flex/files/flex-lvalue.diff b/recipes/flex/files/flex-lvalue.diff
new file mode 100644
index 0000000000..56ae539a6c
--- /dev/null
+++ b/recipes/flex/files/flex-lvalue.diff
@@ -0,0 +1,36 @@
+Patch from http://bugs.debian.org/cgi-bin/bugreport.cgi/flex-lvalue.diff?bug=194844;msg=10;att=1
+
+according to posix 0,1,2 are already setup and this avoids
+the issues with
+| filter.c: In function 'filter_apply_chain':
+| filter.c:161: error: invalid lvalue in assignment
+| filter.c:163: error: invalid lvalue in assignment
+| filter.c:184: error: invalid lvalue in assignment
+
+
+diff -ur flex-2.5.31.ORIG/filter.c flex-2.5.31/filter.c
+--- flex-2.5.31.ORIG/filter.c 2003-03-25 16:39:08.000000000 +0000
++++ flex-2.5.31/filter.c 2003-05-27 17:00:26.000000000 +0000
+@@ -157,11 +157,8 @@
+ if (chain->filter_func) {
+ int r;
+
+- /* setup streams again */
+- if ((stdin = fdopen (0, "r")) == NULL)
+- flexfatal (_("fdopen(0) failed"));
+- if ((stdout = fdopen (1, "w")) == NULL)
+- flexfatal (_("fdopen(1) failed"));
++ /* POSIX says we inherit fd[0-2], so we don't need
++ to do anything to them here */
+
+ if ((r = chain->filter_func (chain)) == -1)
+ flexfatal (_("filter_func failed"));
+@@ -181,8 +178,6 @@
+ if (dup2 (pipes[1], 1) == -1)
+ flexfatal (_("dup2(pipes[1],1)"));
+ close (pipes[1]);
+- if ((stdout = fdopen (1, "w")) == NULL)
+- flexfatal (_("fdopen(1) failed"));
+
+ return true;
+ }
diff --git a/recipes/flex/flex-2.5.31/include.patch b/recipes/flex/flex-2.5.31/include.patch
new file mode 100644
index 0000000000..b60dcb29de
--- /dev/null
+++ b/recipes/flex/flex-2.5.31/include.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- flex-2.5.31/Makefile.am~include
++++ flex-2.5.31/Makefile.am
+@@ -141,7 +141,7 @@
+ tests
+
+ localedir = $(datadir)/locale
+-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
++AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
+ LIBS = @LIBINTL@ @LIBS@
+
+ skel.c: flex.skl mkskel.sh flexint.h tables_shared.h
+--- flex-2.5.31/Makefile.in~include
++++ flex-2.5.31/Makefile.in
+@@ -292,7 +292,7 @@
+
+
+ localedir = $(datadir)/locale
+-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl
++AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl
+
+ # Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
+ #
diff --git a/recipes/flex/flex-native_2.5.31.bb b/recipes/flex/flex-native_2.5.31.bb
new file mode 100644
index 0000000000..1e9354afde
--- /dev/null
+++ b/recipes/flex/flex-native_2.5.31.bb
@@ -0,0 +1,10 @@
+require flex.inc
+inherit native
+PR = "r2"
+
+do_stage () {
+ install -m 0755 flex ${STAGING_BINDIR}
+ oe_libinstall -a libfl ${STAGING_LIBDIR}
+ ln -sf ./flex ${STAGING_BINDIR}/flex++
+ ln -sf ./flex ${STAGING_BINDIR}/lex
+}
diff --git a/recipes/flex/flex.inc b/recipes/flex/flex.inc
new file mode 100644
index 0000000000..048b3cb47d
--- /dev/null
+++ b/recipes/flex/flex.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Flex is a tool for generating programs that recognize lexical patterns in text."
+SECTION = "devel"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-2.5.31.tar.bz2 \
+ file://flex-lvalue.diff;patch=1 \
+ file://fix-gen.patch;patch=1"
+S = "${WORKDIR}/flex-${PV}"
+
+inherit autotools
+
diff --git a/recipes/flex/flex_2.5.31.bb b/recipes/flex/flex_2.5.31.bb
new file mode 100644
index 0000000000..3062e2d8dc
--- /dev/null
+++ b/recipes/flex/flex_2.5.31.bb
@@ -0,0 +1,9 @@
+require flex.inc
+PR = "r4"
+
+SRC_URI += "file://include.patch;patch=1"
+
+do_stage() {
+ oe_libinstall -a libfl ${STAGING_LIBDIR}
+}
+