aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flnx/flnx_0.18.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/flnx/flnx_0.18.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/flnx/flnx_0.18.bb')
-rw-r--r--recipes/flnx/flnx_0.18.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/flnx/flnx_0.18.bb b/recipes/flnx/flnx_0.18.bb
new file mode 100644
index 0000000000..6f84247404
--- /dev/null
+++ b/recipes/flnx/flnx_0.18.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/libs"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+DESCRIPTION = "fltk library for microwindows."
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}-tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/flnx"
+LICENSE = "LGPL"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+python do_fetch () {
+ import os
+ bb.build.exec_func("base_do_fetch", d)
+ if os.access(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), os.R_OK):
+ os.rename(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), bb.data.expand("${DL_DIR}/flnx-${PV}.tar.gz", d))
+}
+
+python do_unpack () {
+ src_uri = bb.data.getVar("SRC_URI", d)
+ src_uri = src_uri.replace("-tar", ".tar")
+ bb.data.setVar("SRC_URI", src_uri, d)
+ bb.build.exec_func("base_do_unpack", d)
+}
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
+}