aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fltk/fltk_1.1.10.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-01-06 15:27:52 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-07 12:16:24 +0100
commit700fd19cd92638de8ea6986abd8bfc7c97aef7e2 (patch)
treefeb31e016990041d4a467be4900069f4bb907f1e /recipes/fltk/fltk_1.1.10.bb
parentee6762f166a4769c8326d552ca59f431b705e86e (diff)
downloadopenembedded-700fd19cd92638de8ea6986abd8bfc7c97aef7e2.tar.gz
fltk: add 1.1.10
Diffstat (limited to 'recipes/fltk/fltk_1.1.10.bb')
-rw-r--r--recipes/fltk/fltk_1.1.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/fltk/fltk_1.1.10.bb b/recipes/fltk/fltk_1.1.10.bb
new file mode 100644
index 0000000000..778c0f35b8
--- /dev/null
+++ b/recipes/fltk/fltk_1.1.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
+
+SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
+ file://disable_test.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/fltk-${PV}"
+
+inherit lib_package autotools_stage binconfig
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+EXTRA_OECONF = "--enable-shared \
+ --enable-threads \
+ --enable-xdbe --enable-xft --enable-gl \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
+}
+
+LEAD_SONAME = "libfltk.so"