aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freenx
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:04:03 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:07:28 +0200
commit1ccac5ff80d342eb7c51d2cc242fe2d86de65deb (patch)
treeb1a7737be7a9b38e48b696f907cb5ccd5fcc9cd4 /recipes/freenx
parent29ceee356c56e0300184ce4dd839c4b3f71da800 (diff)
downloadopenembedded-1ccac5ff80d342eb7c51d2cc242fe2d86de65deb.tar.gz
nxkill: new recipe
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freenx')
-rw-r--r--recipes/freenx/nxkill/Makefile.in.patch13
-rw-r--r--recipes/freenx/nxkill_3.4.0-2.bb17
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes/freenx/nxkill/Makefile.in.patch b/recipes/freenx/nxkill/Makefile.in.patch
new file mode 100644
index 0000000000..4531c856ed
--- /dev/null
+++ b/recipes/freenx/nxkill/Makefile.in.patch
@@ -0,0 +1,13 @@
+Index: nxkill/Makefile.in
+===================================================================
+--- nxkill.orig/Makefile.in
++++ nxkill/Makefile.in
+@@ -12,7 +12,7 @@ LIBVERSION=@LIBVERSION@
+ #
+ CXX = @CXX@
+ CXXFLAGS = @CXXFLAGS@ @X_CFLAGS@ @DEFS@ \
+- -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes \
++ -Wall -Wpointer-arith \
+
+ CXXINCLUDES = -I. -I../nxcomp
+
diff --git a/recipes/freenx/nxkill_3.4.0-2.bb b/recipes/freenx/nxkill_3.4.0-2.bb
new file mode 100644
index 0000000000..05dff11068
--- /dev/null
+++ b/recipes/freenx/nxkill_3.4.0-2.bb
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+
+SRC_URI = "http://64.34.161.181/download/3.4.0/sources/${PN}-${PV}.tar.gz \
+ "
+
+SRC_URI[md5sum] = "a1150d9a51e7eb7d7ae2546a5c139bf7"
+SRC_URI[sha256sum] = "9e45b7c8d780e15113ce6254317da27273fecfdd4d4a07702ac8edbae8cc11f6"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "man1dir=${D}${mandir}" \
+ install
+}