aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freenx
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:04:22 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-25 22:07:29 +0200
commitce9f3075d825cb4e2c788223354bf76461cb0b4c (patch)
tree744c84152b1e4dd5fa69e9b63115b0db4c372a24 /recipes/freenx
parent1ccac5ff80d342eb7c51d2cc242fe2d86de65deb (diff)
downloadopenembedded-ce9f3075d825cb4e2c788223354bf76461cb0b4c.tar.gz
nxssh: new recipe
retrieved from arago and updated to 3.4.0 (arago recipe was done by woglinde) Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freenx')
-rw-r--r--recipes/freenx/nxssh/autotools.patch92
-rw-r--r--recipes/freenx/nxssh/link.patch47
-rw-r--r--recipes/freenx/nxssh/stdarg.patch14
-rw-r--r--recipes/freenx/nxssh_3.4.0-2.bb26
4 files changed, 179 insertions, 0 deletions
diff --git a/recipes/freenx/nxssh/autotools.patch b/recipes/freenx/nxssh/autotools.patch
new file mode 100644
index 0000000000..c34afd9c43
--- /dev/null
+++ b/recipes/freenx/nxssh/autotools.patch
@@ -0,0 +1,92 @@
+Index: nxssh/m4/openssh.m4
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ nxssh/m4/openssh.m4 2008-11-27 23:40:04.338830066 +0100
+@@ -0,0 +1,86 @@
++dnl $Id: aclocal.m4,v 1.6 2005/09/19 16:33:39 tim Exp $
++dnl
++dnl OpenSSH-specific autoconf macros
++dnl
++
++
++dnl OSSH_CHECK_HEADER_FOR_FIELD(field, header, symbol)
++dnl Does AC_EGREP_HEADER on 'header' for the string 'field'
++dnl If found, set 'symbol' to be defined. Cache the result.
++dnl TODO: This is not foolproof, better to compile and read from there
++AC_DEFUN(OSSH_CHECK_HEADER_FOR_FIELD, [
++# look for field '$1' in header '$2'
++ dnl This strips characters illegal to m4 from the header filename
++ ossh_safe=`echo "$2" | sed 'y%./+-%__p_%'`
++ dnl
++ ossh_varname="ossh_cv_$ossh_safe""_has_"$1
++ AC_MSG_CHECKING(for $1 field in $2)
++ AC_CACHE_VAL($ossh_varname, [
++ AC_EGREP_HEADER($1, $2, [ dnl
++ eval "$ossh_varname=yes" dnl
++ ], [ dnl
++ eval "$ossh_varname=no" dnl
++ ]) dnl
++ ])
++ ossh_result=`eval 'echo $'"$ossh_varname"`
++ if test -n "`echo $ossh_varname`"; then
++ AC_MSG_RESULT($ossh_result)
++ if test "x$ossh_result" = "xyes"; then
++ AC_DEFINE($3, 1, [Define if you have $1 in $2])
++ fi
++ else
++ AC_MSG_RESULT(no)
++ fi
++])
++
++dnl OSSH_PATH_ENTROPY_PROG(variablename, command):
++dnl Tidiness function, sets 'undef' if not found, and does the AC_SUBST
++AC_DEFUN(OSSH_PATH_ENTROPY_PROG, [
++ AC_PATH_PROG($1, $2)
++ if test -z "[$]$1" ; then
++ $1="undef"
++ fi
++ AC_SUBST($1)
++])
++
++dnl Check for socklen_t: historically on BSD it is an int, and in
++dnl POSIX 1g it is a type of its own, but some platforms use different
++dnl types for the argument to getsockopt, getpeername, etc. So we
++dnl have to test to find something that will work.
++AC_DEFUN([TYPE_SOCKLEN_T],
++[
++ AC_CHECK_TYPE([socklen_t], ,[
++ AC_MSG_CHECKING([for socklen_t equivalent])
++ AC_CACHE_VAL([curl_cv_socklen_t_equiv],
++ [
++ # Systems have either "struct sockaddr *" or
++ # "void *" as the second argument to getpeername
++ curl_cv_socklen_t_equiv=
++ for arg2 in "struct sockaddr" void; do
++ for t in int size_t unsigned long "unsigned long"; do
++ AC_TRY_COMPILE([
++ #include <sys/types.h>
++ #include <sys/socket.h>
++
++ int getpeername (int, $arg2 *, $t *);
++ ],[
++ $t len;
++ getpeername(0,0,&len);
++ ],[
++ curl_cv_socklen_t_equiv="$t"
++ break
++ ])
++ done
++ done
++
++ if test "x$curl_cv_socklen_t_equiv" = x; then
++ AC_MSG_ERROR([Cannot find a type to use in place of socklen_t])
++ fi
++ ])
++ AC_MSG_RESULT($curl_cv_socklen_t_equiv)
++ AC_DEFINE_UNQUOTED(socklen_t, $curl_cv_socklen_t_equiv,
++ [type to use in place of socklen_t if not defined])],
++ [#include <sys/types.h>
++#include <sys/socket.h>])
++])
++
+
diff --git a/recipes/freenx/nxssh/link.patch b/recipes/freenx/nxssh/link.patch
new file mode 100644
index 0000000000..a4f90a014a
--- /dev/null
+++ b/recipes/freenx/nxssh/link.patch
@@ -0,0 +1,47 @@
+Index: nxssh/Makefile.in
+===================================================================
+--- nxssh.orig/Makefile.in 2007-09-11 23:32:52.000000000 +0200
++++ nxssh/Makefile.in 2008-11-28 00:17:47.994353269 +0100
+@@ -136,32 +136,32 @@
+ $(RANLIB) $@
+
+ nxssh$(EXEEXT): $(LIBCOMPAT) libssh.a $(SSHOBJS)
+- $(LD) -o $@ $(SSHOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS) $(NXCOMPLIBS)
++ $(CC) -o $@ $(SSHOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS) $(NXCOMPLIBS)
+
+ nxsshd$(EXEEXT): libssh.a $(LIBCOMPAT) $(SSHDOBJS)
+- $(LD) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBSELINUX) $(SSHDLIBS) $(LIBS)
++ $(CC) -o $@ $(SSHDOBJS) $(LDFLAGS) -lssh -lopenbsd-compat $(LIBWRAP) $(LIBPAM) $(LIBSELINUX) $(SSHDLIBS) $(LIBS)
+
+ nxssh-keygen$(EXEEXT): $(LIBCOMPAT) libssh.a ssh-keygen.o
+- $(LD) -o $@ ssh-keygen.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
++ $(CC) -o $@ ssh-keygen.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
+
+ ssh-keysign$(EXEEXT): $(LIBCOMPAT) libssh.a ssh-keysign.o
+- $(LD) -o $@ ssh-keysign.o readconf.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
++ $(CC) -o $@ ssh-keysign.o readconf.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
+
+ ssh-keyscan$(EXEEXT): $(LIBCOMPAT) libssh.a ssh-keyscan.o
+- $(LD) -o $@ ssh-keyscan.o $(LDFLAGS) -lssh -lopenbsd-compat -lssh $(LIBS)
++ $(CC) -o $@ ssh-keyscan.o $(LDFLAGS) -lssh -lopenbsd-compat -lssh $(LIBS)
+
+ sftp-server$(EXEEXT): $(LIBCOMPAT) libssh.a sftp.o sftp-common.o sftp-server.o
+- $(LD) -o $@ sftp-server.o sftp-common.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
++ $(CC) -o $@ sftp-server.o sftp-common.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
+
+ sftp$(EXEEXT): $(LIBCOMPAT) libssh.a sftp.o sftp-client.o sftp-common.o sftp-glob.o progressmeter.o
+- $(LD) -o $@ progressmeter.o sftp.o sftp-client.o sftp-common.o sftp-glob.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS) $(LIBEDIT)
++ $(CC) -o $@ progressmeter.o sftp.o sftp-client.o sftp-common.o sftp-glob.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS) $(LIBEDIT)
+
+ ssh-rand-helper${EXEEXT}: $(LIBCOMPAT) libssh.a ssh-rand-helper.o
+- $(LD) -o $@ ssh-rand-helper.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
++ $(CC) -o $@ ssh-rand-helper.o $(LDFLAGS) -lssh -lopenbsd-compat $(LIBS)
+
+ # test driver for the loginrec code - not built by default
+ logintest: logintest.o $(LIBCOMPAT) libssh.a loginrec.o
+- $(LD) -o $@ logintest.o $(LDFLAGS) loginrec.o -lopenbsd-compat -lssh $(LIBS)
++ $(CC) -o $@ logintest.o $(LDFLAGS) loginrec.o -lopenbsd-compat -lssh $(LIBS)
+
+ $(CONFIGFILES): $(CONFIGFILES_IN)
+ conffile=`echo $@ | sed 's/.out$$//'`; \
+
diff --git a/recipes/freenx/nxssh/stdarg.patch b/recipes/freenx/nxssh/stdarg.patch
new file mode 100644
index 0000000000..67f30df501
--- /dev/null
+++ b/recipes/freenx/nxssh/stdarg.patch
@@ -0,0 +1,14 @@
+Index: nxssh/log.h
+===================================================================
+--- nxssh.orig/log.h 2008-11-28 00:10:52.817729265 +0100
++++ nxssh/log.h 2008-11-28 00:11:12.842702590 +0100
+@@ -15,6 +15,8 @@
+ #ifndef SSH_LOG_H
+ #define SSH_LOG_H
+
++#include <stdarg.h>
++
+ /* Supported syslog facilities and levels. */
+ typedef enum {
+ SYSLOG_FACILITY_DAEMON,
+
diff --git a/recipes/freenx/nxssh_3.4.0-2.bb b/recipes/freenx/nxssh_3.4.0-2.bb
new file mode 100644
index 0000000000..acf25a5914
--- /dev/null
+++ b/recipes/freenx/nxssh_3.4.0-2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "The nxssh fork from nomachine"
+HOMEPAGE = "http://www.nomachine.com/"
+LICENSE = "BSD/OPENSSH"
+PR = "r0"
+
+DEPENDS = "openssl libxcomp"
+
+inherit gettext
+
+SRC_URI = "http://64.34.161.181/download/3.4.0/sources/${PN}-${PV}.tar.gz \
+ file://autotools.patch \
+ file://stdarg.patch \
+ file://link.patch \
+ "
+
+SRC_URI[md5sum] = "18b81d850223ea84de244f8a9509c4b1"
+SRC_URI[sha256sum] = "71f88acb6b1135ddd2ea1a172df5dbcf260d2d4c0805f857635ce2acbcf1212e"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools gettext
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -s -m 0755 nxssh ${D}${bindir}/
+}