aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fso-abyss_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-02-26 21:14:06 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-02-26 21:14:06 +0100
commit7b1386a2d52c7405c8412257aaf6c1f05a795726 (patch)
tree3b8dbd7b3e1870b58b7c0feaf2b1b8468603e6cd /recipes/freesmartphone/fso-abyss_git.bb
parent9ac4de8c015c991b8210bdea9bb472633110c268 (diff)
downloadopenembedded-7b1386a2d52c7405c8412257aaf6c1f05a795726.tar.gz
libgsm0710mux: move configuration to fso-abyss; remove 3d7k which will never see the light of day
Diffstat (limited to 'recipes/freesmartphone/fso-abyss_git.bb')
-rw-r--r--recipes/freesmartphone/fso-abyss_git.bb25
1 files changed, 24 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fso-abyss_git.bb b/recipes/freesmartphone/fso-abyss_git.bb
index dc8cbf88b5..e3335460db 100644
--- a/recipes/freesmartphone/fso-abyss_git.bb
+++ b/recipes/freesmartphone/fso-abyss_git.bb
@@ -9,9 +9,32 @@ PR = "r0"
SRC_URI = "\
${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
+ file://fso-abyss.conf \
"
S = "${WORKDIR}/git"
inherit autotools
-FILES_${PN} += "${datadir}"
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fso-abyss.conf ${D}${sysconfdir}/
+}
+
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+ ${sysconfdir}/fso-abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/fso-abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
+
+
+