aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fsogsmd_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-11 16:21:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-11 16:55:01 +0100
commit0450653a9e28a36421f17935e6616ae40cb10daa (patch)
treee75688dd9bab732028060a79a0c73ad379a65400 /recipes/freesmartphone/fsogsmd_git.bb
parent8f58eb85cda95f96db4a3e8b2f0ba5830430182f (diff)
downloadopenembedded-0450653a9e28a36421f17935e6616ae40cb10daa.tar.gz
fso: add .conf files to CONFFILES, remove .service file for fsogsmd for SHR
* fsogsmd is installed in SHR images only for testing purposes, but .service file makes dbus trying to autostart it, which conflicts with ogsmd running by default from frameworkd. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/freesmartphone/fsogsmd_git.bb')
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
index ec46d62ff3..f6adeeb2c3 100644
--- a/recipes/freesmartphone/fsogsmd_git.bb
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
PV = "0.2.0+gitr${SRCREV}"
DEPENDS += "libfsoresource libgsm0710mux"
@@ -12,4 +12,10 @@ do_install_append() {
install -m 0644 ${WORKDIR}/fsogsmd.conf ${D}${sysconfdir}/freesmartphone/
}
+do_install_append_shr() {
+ # remove .service file to disable fsogsmd autostart
+ rm -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.ogsmd.service
+}
+
FILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"