aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/libgsm0710mux_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/freesmartphone/libgsm0710mux_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freesmartphone/libgsm0710mux_git.bb')
-rw-r--r--recipes/freesmartphone/libgsm0710mux_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/freesmartphone/libgsm0710mux_git.bb b/recipes/freesmartphone/libgsm0710mux_git.bb
new file mode 100644
index 0000000000..1d69e3d9d3
--- /dev/null
+++ b/recipes/freesmartphone/libgsm0710mux_git.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "A GSM 07.10 Multiplexing Engine"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+LICENSE = "GPL"
+SECTION = "devel"
+DEPENDS = "libgsm0710 vala-native glib-2.0"
+PV = "0.3.1+gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/libgsm0710mux;protocol=git;branch=master \
+ file://abyss.conf \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools_stage pkgconfig
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
+}
+
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+# ship vapi file
+FILES_${PN}-dev += "${datadir}/vala"
+
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"