aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/mdbus_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-02-12 21:12:44 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-02-12 21:15:04 +0100
commitc9fbceb7c35e6572c04deb0babda1ff8cf4c3457 (patch)
tree1c1e2be966d4db91212ab678441eceef5a40a917 /recipes/freesmartphone/mdbus_git.bb
parent550d4902f4f5a369d8fe378c364efcc2346a2d05 (diff)
downloadopenembedded-c9fbceb7c35e6572c04deb0babda1ff8cf4c3457.tar.gz
freesmartphone: rename mickeydbus(2) to mdbus(2), fso-term is now called mterm2
Diffstat (limited to 'recipes/freesmartphone/mdbus_git.bb')
-rw-r--r--recipes/freesmartphone/mdbus_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/freesmartphone/mdbus_git.bb b/recipes/freesmartphone/mdbus_git.bb
new file mode 100644
index 0000000000..229ff7f1fd
--- /dev/null
+++ b/recipes/freesmartphone/mdbus_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Mickey's DBus introspection and calling Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.9.2+gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeydbus/mdbus ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+ python-pygobject \
+ python-pprint \
+ python-xml \
+"
+
+PACKAGE_ARCH_${PN} = "all"
+