aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/menu-freesmartphone.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-06 23:51:34 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-07 02:49:56 +0200
commit8aaba52bea14032340a37959af4a57047cb03c1b (patch)
treea8e45a14240e95aa7058c8f88476448f831a274f /recipes/freesmartphone/menu-freesmartphone.bb
parentc579f58d519f6e2e58a3b5acc52fc3d9cd953c3d (diff)
downloadopenembedded-8aaba52bea14032340a37959af4a57047cb03c1b.tar.gz
freesmartphone: catch up with milestone5.5 and SHR/import
Diffstat (limited to 'recipes/freesmartphone/menu-freesmartphone.bb')
-rw-r--r--recipes/freesmartphone/menu-freesmartphone.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/freesmartphone/menu-freesmartphone.bb b/recipes/freesmartphone/menu-freesmartphone.bb
new file mode 100644
index 0000000000..2d1f6145c4
--- /dev/null
+++ b/recipes/freesmartphone/menu-freesmartphone.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "XDG menu file for the freesmartphone.org project"
+LICENSE = "PD"
+PV = "0.1"
+PR = "r0"
+
+SRC_URI = "file://applications.menu"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/xdg/menus
+ install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
+}
+
+RPROVIDES_${PN} = "e-wm-menu"
+CONFFILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
+FILES_${PN} = "${sysconfdir}/xdg/menus/applications.menu"
+
+PACKAGE_ARCH_${PN} = "all"
+