summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/opimd-utils_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-07 12:36:36 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-07 12:36:55 +0100
commitf3472b0f09a31fe9d989cfa60d2d12d4c44d1a48 (patch)
treec498fbb5f7b8c10efd6c5af7534727ca2d5c291a /recipes/freesmartphone/opimd-utils_git.bb
parent54c6f4eb5eb57e97ef365fc98638c402366a9cf9 (diff)
downloadopenembedded-f3472b0f09a31fe9d989cfa60d2d12d4c44d1a48.tar.gz
frameworkd: add patch for shr, merge from shr/merge
Diffstat (limited to 'recipes/freesmartphone/opimd-utils_git.bb')
-rw-r--r--recipes/freesmartphone/opimd-utils_git.bb42
1 files changed, 31 insertions, 11 deletions
diff --git a/recipes/freesmartphone/opimd-utils_git.bb b/recipes/freesmartphone/opimd-utils_git.bb
index 5031ae5c13..68038f34c1 100644
--- a/recipes/freesmartphone/opimd-utils_git.bb
+++ b/recipes/freesmartphone/opimd-utils_git.bb
@@ -1,27 +1,47 @@
DESCRIPTION = "Test scripts for freesmartphone.org opimd interface"
HOMEPAGE = "http://freesmartphone.org"
+SHR_RELEASE ?= "shr"
LICENSE ?= "GPL"
+RDEPENDS = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
SECTION = "x11/application"
PV = "0.0.2+gitr${SRCREV}"
PR = "r0"
inherit setuptools
-SRC_URI = "git://git.shr-project.org/repo/opimd-utils.git;protocol=http"
-S = "${WORKDIR}/git"
+PACKAGES =+ "\
+ ${PN}-cli \
+ ${PN}-notes \
+ ${PN}-data \
+"
-RDEPENDS = "\
- python-elementary \
- python-edbus \
- python-codecs \
- python-shell \
- \
+RDEPENDS_${PN} = "\
+ ${PN}-data \
shr-settings \
- shr-theme \
- frameworkd \
pyphonelog \
+ shr-theme \
+"
+
+RDEPENDS_${PN}-notes = "\
+ ${PN}-data \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-notes \
+ ${PN}-cli \
"
+PACKAGE_ARCH_${PN}-cli = "all"
+PACKAGE_ARCH_${PN}-data = "all"
+PACKAGE_ARCH_${PN}-notes = "all"
+
+SRC_URI = "git://git.shr-project.org/repo/opimd-utils.git;protocol=http"
+S = "${WORKDIR}/git"
FILES_${PN} += "${sysconfdir}/X11/Xsession.d/89opimd-notifier"
FILES_${PN} += "${prefix}/share/applications/"
-FILES_${PN} += "${prefix}/share/pixmaps/opimd-utils/"
+FILES_${PN} += "${prefix}/share/pixmaps/"
+FILES_${PN}-data += "${prefix}/share/pixmaps/opimd-utils/"
+FILES_${PN}-cli += "${prefix}/bin/opimd-cli"
+FILES_${PN}-notes += "${prefix}/bin/opimd-notes"
+FILES_${PN}-notes += "${prefix}/share/pixmaps/opimd-notes.png"
+FILES_${PN}-notes += "${prefix}/share/applications/opimd-notes.desktop"