aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-13 09:01:48 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-19 14:10:42 +0200
commit1ae6c316ae1dd97ead21053f9b4bb0b645c13c1d (patch)
treecdd08e6d8b45b1f042568c30e25feddaf6c379ad /recipes/freesmartphone
parent6a195fedaaf18aa75fc82bd17784a0c47b9913e8 (diff)
downloadopenembedded-1ae6c316ae1dd97ead21053f9b4bb0b645c13c1d.tar.gz
aurora: add initial recipe
Aurora is the new reference UI for the freesmartphone framework. It currently targets only the Palm Pre devices. Later it will support more devices (but only when FSO supports them). Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/aurora/aurora-daemon3
-rw-r--r--recipes/freesmartphone/aurora_git.bb37
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/freesmartphone/aurora/aurora-daemon b/recipes/freesmartphone/aurora/aurora-daemon
new file mode 100644
index 0000000000..73beb1b5fb
--- /dev/null
+++ b/recipes/freesmartphone/aurora/aurora-daemon
@@ -0,0 +1,3 @@
+#!/bin/sh
+export QWS_MOUSE_PROTO="LinuxInput:/dev/input/event6"
+aurora -qws > /tmp/aurora.log 2>&1 &
diff --git a/recipes/freesmartphone/aurora_git.bb b/recipes/freesmartphone/aurora_git.bb
new file mode 100644
index 0000000000..0c24c33c8b
--- /dev/null
+++ b/recipes/freesmartphone/aurora_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Aurora is the new phone UI for the FreeSmartphone framework. It is \
+clean and simple and is build on top of the powerful Declarative component of the Qt framework."
+AUTHOR = "Simon Busch <morphis@gravedo.de>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "fso"
+LICENSE = "GPLv2"
+SRCREV = "6db9e04728bd0434e6b79939ee18be43017afeef"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master \
+ file://aurora-daemon \
+"
+S = "${WORKDIR}/git/aurora"
+
+RDEPENDS_${PN} = "\
+ python-logging \
+ python-textutils \
+ python-dbus \
+ python-pyside-embedded \
+ python-pygobject \
+ python-phoneutils \
+"
+
+inherit autotools python-dir update-rc.d
+
+INITSCRIPT_NAME = "aurora-daemon"
+INITSCRIPT_PARAMS = "defaults 40"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/aurora"