aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freetype
diff options
context:
space:
mode:
authorAlexander Stohr <Alexander.Stohr@gmx.de>2010-10-07 05:27:55 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-10 03:09:03 -0700
commit22b4c17b8e6004dceecbd78a17c951a45a3c9b60 (patch)
treeacfb62520941bbf7347b29b39db12bc62e1bc3ac /recipes/freetype
parentc6c105e40866a2031a59172f545fa7e5c9b747e1 (diff)
downloadopenembedded-22b4c17b8e6004dceecbd78a17c951a45a3c9b60.tar.gz
fix for building freetype-native on a symlinked build environment
patchyfied for 2.2.1, 2.3.6 and 2.3.12 including recipes changes see attachment Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/freetype')
-rw-r--r--recipes/freetype/freetype-2.2.1/configure-using-inodes.patch30
-rw-r--r--recipes/freetype/freetype-2.3.12/configure-using-inodes.patch30
-rw-r--r--recipes/freetype/freetype-2.3.6/configure-using-inodes.patch30
-rw-r--r--recipes/freetype/freetype_2.2.1.bb3
-rw-r--r--recipes/freetype/freetype_2.3.12.bb1
-rw-r--r--recipes/freetype/freetype_2.3.6.bb1
6 files changed, 94 insertions, 1 deletions
diff --git a/recipes/freetype/freetype-2.2.1/configure-using-inodes.patch b/recipes/freetype/freetype-2.2.1/configure-using-inodes.patch
new file mode 100644
index 0000000000..c2bff023cf
--- /dev/null
+++ b/recipes/freetype/freetype-2.2.1/configure-using-inodes.patch
@@ -0,0 +1,30 @@
+http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=75eeb32a2e55ffb3e4102ee56cd913a442d1ac9a
+
+author Werner Lemberg <wl@gnu.org> 2010-10-03 18:17:27 (GMT)
+
+Avoid `configure' issues with symbolic links.
+Based on a patch from Alexander Stohr <Alexander.Stohr@gmx.de>.
+* configure: Compare directories using `ls -id'.
+Check existence of `reference' subdirectory before creating it.
+
+--- freetype.orig/configure 2010-10-07 16:46:51.000000000 +0200
++++ freetype/configure 2010-10-07 16:49:52.000000000 +0200
+@@ -67,10 +67,15 @@
+ abs_curr_dir=`pwd`
+ abs_ft2_dir=`cd "$ft2_dir" && pwd`
+
+-# build a dummy Makefile if we are not building in the source tree
++# build a dummy Makefile if we are not building in the source tree;
++# we use inodes to avoid issues with symbolic links
++inode_src=`ls -id $abs_ft2_dir | sed 's/ .*//'`
++inode_dst=`ls -id $abs_curr_dir | sed 's/ .*//'`
+
+-if test "$abs_curr_dir" != "$abs_ft2_dir"; then
+- mkdir reference
++if test $inode_src -ne $inode_dst; then
++ if test ! -d reference; then
++ mkdir reference
++ fi
+ echo "Copying \`modules.cfg'"
+ cp $abs_ft2_dir/modules.cfg $abs_curr_dir
+ echo "Generating \`Makefile'"
diff --git a/recipes/freetype/freetype-2.3.12/configure-using-inodes.patch b/recipes/freetype/freetype-2.3.12/configure-using-inodes.patch
new file mode 100644
index 0000000000..83dd120359
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.12/configure-using-inodes.patch
@@ -0,0 +1,30 @@
+http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=75eeb32a2e55ffb3e4102ee56cd913a442d1ac9a
+
+author Werner Lemberg <wl@gnu.org> 2010-10-03 18:17:27 (GMT)
+
+Avoid `configure' issues with symbolic links.
+Based on a patch from Alexander Stohr <Alexander.Stohr@gmx.de>.
+* configure: Compare directories using `ls -id'.
+Check existence of `reference' subdirectory before creating it.
+
+--- freetype.orig/configure 2010-10-07 16:46:51.000000000 +0200
++++ freetype/configure 2010-10-07 16:49:52.000000000 +0200
+@@ -78,10 +78,15 @@
+ done
+ fi
+
+-# build a dummy Makefile if we are not building in the source tree
++# build a dummy Makefile if we are not building in the source tree;
++# we use inodes to avoid issues with symbolic links
++inode_src=`ls -id $abs_ft2_dir | sed 's/ .*//'`
++inode_dst=`ls -id $abs_curr_dir | sed 's/ .*//'`
+
+-if test "$abs_curr_dir" != "$abs_ft2_dir"; then
+- mkdir reference
++if test $inode_src -ne $inode_dst; then
++ if test ! -d reference; then
++ mkdir reference
++ fi
+ if test ! -r $abs_curr_dir/modules.cfg; then
+ echo "Copying \`modules.cfg'"
+ cp $abs_ft2_dir/modules.cfg $abs_curr_dir
diff --git a/recipes/freetype/freetype-2.3.6/configure-using-inodes.patch b/recipes/freetype/freetype-2.3.6/configure-using-inodes.patch
new file mode 100644
index 0000000000..c2bff023cf
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.6/configure-using-inodes.patch
@@ -0,0 +1,30 @@
+http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=75eeb32a2e55ffb3e4102ee56cd913a442d1ac9a
+
+author Werner Lemberg <wl@gnu.org> 2010-10-03 18:17:27 (GMT)
+
+Avoid `configure' issues with symbolic links.
+Based on a patch from Alexander Stohr <Alexander.Stohr@gmx.de>.
+* configure: Compare directories using `ls -id'.
+Check existence of `reference' subdirectory before creating it.
+
+--- freetype.orig/configure 2010-10-07 16:46:51.000000000 +0200
++++ freetype/configure 2010-10-07 16:49:52.000000000 +0200
+@@ -67,10 +67,15 @@
+ abs_curr_dir=`pwd`
+ abs_ft2_dir=`cd "$ft2_dir" && pwd`
+
+-# build a dummy Makefile if we are not building in the source tree
++# build a dummy Makefile if we are not building in the source tree;
++# we use inodes to avoid issues with symbolic links
++inode_src=`ls -id $abs_ft2_dir | sed 's/ .*//'`
++inode_dst=`ls -id $abs_curr_dir | sed 's/ .*//'`
+
+-if test "$abs_curr_dir" != "$abs_ft2_dir"; then
+- mkdir reference
++if test $inode_src -ne $inode_dst; then
++ if test ! -d reference; then
++ mkdir reference
++ fi
+ echo "Copying \`modules.cfg'"
+ cp $abs_ft2_dir/modules.cfg $abs_curr_dir
+ echo "Generating \`Makefile'"
diff --git a/recipes/freetype/freetype_2.2.1.bb b/recipes/freetype/freetype_2.2.1.bb
index b67da311a2..dbd8efbd2a 100644
--- a/recipes/freetype/freetype_2.2.1.bb
+++ b/recipes/freetype/freetype_2.2.1.bb
@@ -5,7 +5,8 @@ PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
file://configure.patch \
- file://no-hardcode.patch"
+ file://no-hardcode.patch \
+ file://configure-using-inodes.patch"
S = "${WORKDIR}/freetype-${PV}"
inherit autotools pkgconfig binconfig
diff --git a/recipes/freetype/freetype_2.3.12.bb b/recipes/freetype/freetype_2.3.12.bb
index f7c3d1cb65..fe567f41bb 100644
--- a/recipes/freetype/freetype_2.3.12.bb
+++ b/recipes/freetype/freetype_2.3.12.bb
@@ -9,6 +9,7 @@ SRC_URI = "\
file://no-hardcode.patch \
file://fix-configure.patch \
file://libtool-tag.patch \
+ file://configure-using-inodes.patch \
"
S = "${WORKDIR}/freetype-${PV}"
diff --git a/recipes/freetype/freetype_2.3.6.bb b/recipes/freetype/freetype_2.3.6.bb
index e92bef8870..0c93538c14 100644
--- a/recipes/freetype/freetype_2.3.6.bb
+++ b/recipes/freetype/freetype_2.3.6.bb
@@ -8,6 +8,7 @@ SRC_URI = "\
file://no-hardcode.patch \
file://fix-configure.patch \
file://libtool-tag.patch \
+ file://configure-using-inodes.patch \
"
S = "${WORKDIR}/freetype-${PV}"