aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freetype
diff options
context:
space:
mode:
authorEnrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>2010-03-28 16:45:36 +0200
committerEnrico Scholz <enrico.scholz@sigma-chemnitz.de>2010-07-15 11:38:00 +0200
commitaaac36c39e301995029cb40ae40fa8af277694dc (patch)
tree47e3fe809d984d35a79df2af8948af7a65c6abb4 /recipes/freetype
parent9b5d718684ee37bfd117e02ea3af763847368788 (diff)
downloadopenembedded-aaac36c39e301995029cb40ae40fa8af277694dc.tar.gz
freetype: updated to 2.3.12
That's (nearly) a copy of the old 2.3.11 recipe. Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
Diffstat (limited to 'recipes/freetype')
-rw-r--r--recipes/freetype/freetype-2.3.12/fix-configure.patch13
-rw-r--r--recipes/freetype/freetype-2.3.12/libtool-tag.patch20
-rw-r--r--recipes/freetype/freetype_2.3.12.bb40
3 files changed, 73 insertions, 0 deletions
diff --git a/recipes/freetype/freetype-2.3.12/fix-configure.patch b/recipes/freetype/freetype-2.3.12/fix-configure.patch
new file mode 100644
index 0000000000..78e76ebce7
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.12/fix-configure.patch
@@ -0,0 +1,13 @@
+Index: freetype-2.3.6/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.6.orig/builds/unix/configure.ac
++++ freetype-2.3.6/builds/unix/configure.ac
+@@ -506,8 +506,6 @@ AC_SUBST([FT2_EXTRA_LIBS])
+ AC_SUBST([SYSTEM_ZLIB])
+
+
+-LT_INIT(win32-dll)
+-
+ AC_SUBST([hardcode_libdir_flag_spec])
+ AC_SUBST([wl])
+ AC_SUBST([build_libtool_libs])
diff --git a/recipes/freetype/freetype-2.3.12/libtool-tag.patch b/recipes/freetype/freetype-2.3.12/libtool-tag.patch
new file mode 100644
index 0000000000..356a256e4c
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.12/libtool-tag.patch
@@ -0,0 +1,20 @@
+--- freetype-2.3.6/builds/unix/unix-cc.in
++++ freetype-2.3.6/builds/unix/unix-cc.in
+@@ -88,7 +88,7 @@
+ #
+ #
+ CCraw := $(CC)
+-CC := $(LIBTOOL) --mode=compile $(CCraw)
++CC := $(LIBTOOL) --tag=CC --mode=compile $(CCraw)
+
+ # Linker flags.
+ #
+@@ -105,7 +105,7 @@
+
+ # Library linking
+ #
+-LINK_LIBRARY = $(LIBTOOL) --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
++LINK_LIBRARY = $(LIBTOOL) --tag=CC --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
+ -rpath $(libdir) -version-info $(version_info) \
+ $(LDFLAGS) -no-undefined \
+ # -export-symbols $(EXPORTS_LIST)
diff --git a/recipes/freetype/freetype_2.3.12.bb b/recipes/freetype/freetype_2.3.12.bb
new file mode 100644
index 0000000000..fb57094095
--- /dev/null
+++ b/recipes/freetype/freetype_2.3.12.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://no-hardcode.patch \
+ file://fix-configure.patch \
+ file://libtool-tag.patch \
+"
+S = "${WORKDIR}/freetype-${PV}"
+
+SRC_URI[md5sum] = "e974a82e5939be8e05ee65f07275d7c5"
+SRC_URI[sha256sum] = "3b96438f016a62b676c1d2089c00ca777f710d19f6aefa66ccf068d360db3e92"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+ cd builds/unix
+ libtoolize --force --copy
+ gnu-configize --force
+ aclocal -I .
+ autoconf
+ cd ${S}
+ oe_runconf
+}
+
+do_compile_prepend() {
+ ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"