aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freetype
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-29 22:07:31 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-29 22:40:17 +0200
commitf3438bd86a1a18444cffef4b21138681aa3996ca (patch)
tree1b234ddff0417ebc32877e45af107ed43b77cc85 /recipes/freetype
parenta5d3960e0346c16f98a75f3f4b1d8d0e7f85f527 (diff)
downloadopenembedded-f3438bd86a1a18444cffef4b21138681aa3996ca.tar.gz
freetype 2.3.11: add new version
This version fixes the following issue with navit: https://bugzilla.redhat.com/show_bug.cgi?id=506840 Thanks woglinde for pointing out that the new version had the fixes: <woglinde> bestway is to update to freetype 2.3.11
Diffstat (limited to 'recipes/freetype')
-rw-r--r--recipes/freetype/freetype-2.3.11/fix-configure.patch13
-rw-r--r--recipes/freetype/freetype-2.3.11/libtool-tag.patch20
-rw-r--r--recipes/freetype/freetype_2.3.11.bb40
3 files changed, 73 insertions, 0 deletions
diff --git a/recipes/freetype/freetype-2.3.11/fix-configure.patch b/recipes/freetype/freetype-2.3.11/fix-configure.patch
new file mode 100644
index 0000000000..ecd96738d4
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.11/fix-configure.patch
@@ -0,0 +1,13 @@
+Index: freetype-2.3.6/builds/unix/configure.ac
+===================================================================
+--- freetype-2.3.6.orig/builds/unix/configure.ac
++++ freetype-2.3.6/builds/unix/configure.ac
+@@ -506,8 +506,6 @@ AC_SUBST([FT2_EXTRA_LIBS])
+ AC_SUBST([SYSTEM_ZLIB])
+
+
+-LT_INIT(win32-dll)
+-
+ AC_SUBST([hardcode_libdir_flag_spec])
+ AC_SUBST([wl])
+ AC_SUBST([build_libtool_libs])
diff --git a/recipes/freetype/freetype-2.3.11/libtool-tag.patch b/recipes/freetype/freetype-2.3.11/libtool-tag.patch
new file mode 100644
index 0000000000..2f096cdd46
--- /dev/null
+++ b/recipes/freetype/freetype-2.3.11/libtool-tag.patch
@@ -0,0 +1,20 @@
+--- freetype-2.3.6/builds/unix/unix-cc.in
++++ freetype-2.3.6/builds/unix/unix-cc.in
+@@ -88,7 +88,7 @@
+ #
+ #
+ CCraw := $(CC)
+-CC := $(LIBTOOL) --mode=compile $(CCraw)
++CC := $(LIBTOOL) --tag=CC --mode=compile $(CCraw)
+
+ # Linker flags.
+ #
+@@ -105,7 +105,7 @@
+
+ # Library linking
+ #
+-LINK_LIBRARY = $(LIBTOOL) --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
++LINK_LIBRARY = $(LIBTOOL) --tag=CC --mode=link $(CCraw) -o $@ $(OBJECTS_LIST) \
+ -rpath $(libdir) -version-info $(version_info) \
+ $(LDFLAGS) -no-undefined \
+ # -export-symbols $(EXPORTS_LIST)
diff --git a/recipes/freetype/freetype_2.3.11.bb b/recipes/freetype/freetype_2.3.11.bb
new file mode 100644
index 0000000000..32d3f19d95
--- /dev/null
+++ b/recipes/freetype/freetype_2.3.11.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://no-hardcode.patch;patch=1 \
+ file://fix-configure.patch;patch=1 \
+ file://libtool-tag.patch;patch=1 \
+"
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+ cd builds/unix
+ libtoolize --force --copy
+ gnu-configize --force
+ aclocal -I .
+ autoconf
+ cd ${S}
+ oe_runconf
+}
+
+do_compile_prepend() {
+ ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+BBCLASSEXTEND = "native"
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+
+SRC_URI[md5sum] = "519c7cbf5cbd72ffa822c66844d3114c"
+SRC_URI[sha256sum] = "8a033b1e6018a1e9ea381b09b2347b02c6686bdf7e4ee86a6714b6b90f1e2ec9"