aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/frotz/frotz_2.43.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/frotz/frotz_2.43.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/frotz/frotz_2.43.bb')
-rw-r--r--recipes/frotz/frotz_2.43.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/frotz/frotz_2.43.bb b/recipes/frotz/frotz_2.43.bb
new file mode 100644
index 0000000000..9cace09992
--- /dev/null
+++ b/recipes/frotz/frotz_2.43.bb
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
+HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
+SECTION = "console/games"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
+ file://Makefile-${PV}.patch;patch=1 \
+ file://remove_root_restriction.patch;patch=1 "
+
+do_configure() {
+ rm -f ${SourceTree}/frotz.conf
+}
+
+EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
+
+do_compile() {
+ oe_runmake frotz
+}
+
+do_install() {
+ oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
+}