aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fs
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-25 23:15:14 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-26 22:50:53 +0100
commit106d2dcc40667f4370f936c16a52dccb14d9f759 (patch)
treeea229d59072e24b4e757b640473c51cda845d08d /recipes/fs
parent46169e02d90fd5c57425a8078e92ac30643afe3d (diff)
downloadopenembedded-106d2dcc40667f4370f936c16a52dccb14d9f759.tar.gz
fs: fix header inclusions and bump PR
Diffstat (limited to 'recipes/fs')
-rw-r--r--recipes/fs/files/fontsproto.patch27
-rw-r--r--recipes/fs/files/xtrans.patch21
-rw-r--r--recipes/fs/fs_cvs.bb8
3 files changed, 55 insertions, 1 deletions
diff --git a/recipes/fs/files/fontsproto.patch b/recipes/fs/files/fontsproto.patch
new file mode 100644
index 0000000000..1032b486af
--- /dev/null
+++ b/recipes/fs/files/fontsproto.patch
@@ -0,0 +1,27 @@
+Index: FS/FSlibint.h
+===================================================================
+--- FS.orig/FSlibint.h 2011-02-25 22:34:43.884558121 +0100
++++ FS/FSlibint.h 2011-02-25 22:35:15.230223119 +0100
+@@ -72,8 +72,8 @@
+ #endif /* USG */
+
+ #include "FSlib.h"
+-#include "FSproto.h"
+ #include "FSlibos.h"
++#include <X11/fonts/FSproto.h>
+ #include <errno.h>
+ #include <stddef.h>
+
+Index: FS/configure.ac
+===================================================================
+--- FS.orig/configure.ac 2011-02-25 22:35:23.977928121 +0100
++++ FS/configure.ac 2011-02-25 22:35:39.622413120 +0100
+@@ -19,7 +19,7 @@
+ AC_PROG_CC
+
+ # Checks for pkg-config packages
+-PKG_CHECK_MODULES(FS, xfont xtrans)
++PKG_CHECK_MODULES(FS, xfont xtrans fontsproto)
+
+ # Checks for libraries.
+
diff --git a/recipes/fs/files/xtrans.patch b/recipes/fs/files/xtrans.patch
new file mode 100644
index 0000000000..e628a2604d
--- /dev/null
+++ b/recipes/fs/files/xtrans.patch
@@ -0,0 +1,21 @@
+Index: FS/fs_trans.h
+===================================================================
+--- FS.orig/fs_trans.h 2011-02-25 23:00:34.025908119 +0100
++++ FS/fs_trans.h 2011-02-25 23:01:19.165133120 +0100
+@@ -24,4 +24,4 @@
+
+ #define FS_t
+ #define TRANS_CLIENT
+-#include <Xtrans.h>
++#include <X11/Xtrans/Xtrans.h>
+Index: FS/fs_trans.c
+===================================================================
+--- FS.orig/fs_trans.c 2011-02-25 23:08:51.177693119 +0100
++++ FS/fs_trans.c 2011-02-25 23:09:00.378958118 +0100
+@@ -28,5 +28,5 @@
+
+ #define FS_t
+ #define TRANS_CLIENT
+-#include <transport.c>
++#include <X11/Xtrans/transport.c>
+
diff --git a/recipes/fs/fs_cvs.bb b/recipes/fs/fs_cvs.bb
index 9dcba5708b..b4baee6fe5 100644
--- a/recipes/fs/fs_cvs.bb
+++ b/recipes/fs/fs_cvs.bb
@@ -4,7 +4,13 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "libxfont xtrans"
-SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=FS"
+PR = "r1"
+
+SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=FS \
+ file://fontsproto.patch \
+ file://xtrans.patch \
+ "
+
S = "${WORKDIR}/FS"
inherit autotools pkgconfig