aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fsx-linux
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fsx-linux
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fsx-linux')
-rw-r--r--recipes/fsx-linux/fsx-linux_0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/fsx-linux/fsx-linux_0.0.bb b/recipes/fsx-linux/fsx-linux_0.0.bb
new file mode 100644
index 0000000000..294af8fdfd
--- /dev/null
+++ b/recipes/fsx-linux/fsx-linux_0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Asynchronous I/O stress util"
+
+SRC_URI = "http://www.codemonkey.org.uk/projects/fsx/fsx-linux.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+
+ cd ${S} && ${CC} fsx-linux.c -o fsx-linux -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fsx-linux ${D}${bindir}
+}