aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fvwm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/fvwm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/fvwm')
-rw-r--r--recipes/fvwm/files/acinclude.m4.patch32
-rw-r--r--recipes/fvwm/files/oe-configure.ac.patch56
-rw-r--r--recipes/fvwm/files/upstream-configure.ac.patch26
-rw-r--r--recipes/fvwm/fvwm_2.5.26.bb46
4 files changed, 160 insertions, 0 deletions
diff --git a/recipes/fvwm/files/acinclude.m4.patch b/recipes/fvwm/files/acinclude.m4.patch
new file mode 100644
index 0000000000..59c4275bf3
--- /dev/null
+++ b/recipes/fvwm/files/acinclude.m4.patch
@@ -0,0 +1,32 @@
+upstream: OE-only
+origin: Yuri Bushmelev <jay4mail at gmail.com>
+comment: disable xft-config calls while cross-compiling
+--- fvwm-2.5.26/acinclude.m4.orig 2008-06-10 01:53:46.000000000 +0400
++++ fvwm-2.5.26/acinclude.m4 2008-06-10 01:53:51.000000000 +0400
+@@ -1225,14 +1225,14 @@
+ XFT_CONFIG=$xft_config_prefix/bin/xft-config
+ fi
+ fi
+-AC_PATH_PROG(XFT_CONFIG, xft-config, no)
++dnl AC_PATH_PROG(XFT_CONFIG, xft-config, no)
+
+ min_xft_version=ifelse([$1], ,2.0.0,$1)
+ AC_MSG_CHECKING(for Xft - version >= $min_xft_version)
+ no_xft=""
+ pkg_config_xft_exists=""
+
+-if test "$XFT_CONFIG" = "no" ; then
++dnl if test "$XFT_CONFIG" = "no" ; then
+ if test "x$PKG_CONFIG" != "xno" ; then
+ if $PKG_CONFIG --exists 'xft' ; then
+ if $PKG_CONFIG --exists 'xft >= $1' ; then
+@@ -1249,7 +1249,8 @@
+ else
+ no_xft=yes
+ fi
+-else
++dnl else
++if false; then
+ XFT_CFLAGS=`$XFT_CONFIG $xft_config_args --cflags`
+ XFT_LIBS=`$XFT_CONFIG $xft_config_args --libs`
+ xft_config_major_version=`$XFT_CONFIG $xft_config_args --version | \
diff --git a/recipes/fvwm/files/oe-configure.ac.patch b/recipes/fvwm/files/oe-configure.ac.patch
new file mode 100644
index 0000000000..c140cff5dd
--- /dev/null
+++ b/recipes/fvwm/files/oe-configure.ac.patch
@@ -0,0 +1,56 @@
+upstream: OE-only
+origin: Yuri Bushmelev <jay4mail at gmail.com>
+comment: disable mkstemp() safety check, X11/keysym.h check and old libstroke check
+--- fvwm-2.5.26/configure.ac.orig 2008-06-11 15:44:28.000000000 +0400
++++ fvwm-2.5.26/configure.ac 2008-06-11 15:44:46.000000000 +0400
+@@ -1405,7 +1407,8 @@
+
+ # check for mkstemp, see the discution on this subject on the fvwm workers
+ # list (2001-02-16 and 2001-02-24)
+-AM_SAFETY_CHECK_MKSTEMP
++#AM_SAFETY_CHECK_MKSTEMP
++AC_DEFINE(HAVE_SAFETY_MKSTEMP)
+
+ # If we do not have atexit(), then check for on_exit()
+ if test x$ac_cv_func_atexit = xno; then
+@@ -1465,23 +1468,23 @@
+ problem_gnomehints=": Explicitly disabled"
+ fi
+
+-# Define some compatibility macros needed for config.h.
+-mg_DEFINE_IF_NOT([#include <X11/keysym.h>],
+- [defined XK_Page_Up && defined XK_Page_Down],
+- [COMPAT_OLD_KEYSYMDEF], [$X_CFLAGS],
+- [Old AIX systems (3.2.5) don't define some common keysyms.])
+-AH_VERBATIM([_COMPAT_OLD_KEYSYMDEF],
+-[#ifdef COMPAT_OLD_KEYSYMDEF
+-# define XK_Page_Up XK_Prior
+-# define XK_Page_Down XK_Next
+-#endif])
+-
+-if test x"$with_stroke" = xyes; then
+- mg_DEFINE_IF_NOT([#include <stroke.h>],
+- [defined STROKE_MAX_SEQUENCE],
+- [COMPAT_OLD_LIBSTROKE], [$stroke_CFLAGS],
+- [Old libstroke <= 0.4 does not use STROKE_ prefix for constants.])
+-fi
++## Define some compatibility macros needed for config.h.
++#mg_DEFINE_IF_NOT([#include <X11/keysym.h>],
++# [defined XK_Page_Up && defined XK_Page_Down],
++# [COMPAT_OLD_KEYSYMDEF], [$X_CFLAGS],
++# [Old AIX systems (3.2.5) don't define some common keysyms.])
++#AH_VERBATIM([_COMPAT_OLD_KEYSYMDEF],
++#[#ifdef COMPAT_OLD_KEYSYMDEF
++## define XK_Page_Up XK_Prior
++## define XK_Page_Down XK_Next
++##endif])
++
++#if test x"$with_stroke" = xyes; then
++# mg_DEFINE_IF_NOT([#include <stroke.h>],
++# [defined STROKE_MAX_SEQUENCE],
++# [COMPAT_OLD_LIBSTROKE], [$stroke_CFLAGS],
++# [Old libstroke <= 0.4 does not use STROKE_ prefix for constants.])
++#fi
+ AH_VERBATIM([_COMPAT_OLD_LIBSTROKE],
+ [#ifdef COMPAT_OLD_LIBSTROKE
+ /* currently we only use one constant */
diff --git a/recipes/fvwm/files/upstream-configure.ac.patch b/recipes/fvwm/files/upstream-configure.ac.patch
new file mode 100644
index 0000000000..e897d58fed
--- /dev/null
+++ b/recipes/fvwm/files/upstream-configure.ac.patch
@@ -0,0 +1,26 @@
+upstream: http://fvwm.lair.be/viewtopic.php?f=49&t=2107
+status: pending
+origin: Yuri Bushmelev <jay4mail at gmail.com>
+comment: fixes libs detection in configure when cross-compiling
+--- fvwm-2.5.26/configure.ac.orig 2008-06-11 15:44:28.000000000 +0400
++++ fvwm-2.5.26/configure.ac 2008-06-11 15:44:46.000000000 +0400
+@@ -792,7 +792,8 @@
+ problem_xpm=": Internal xpm detection logic error"
+ fi
+ fi],
+- [with_xpm=no; problem_xpm=": Xpm test error, see config.log"])
++ [with_xpm=no; problem_xpm=": Xpm test error, see config.log"],
++ [echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ AC_MSG_RESULT($with_xpm)
+ CPPFLAGS="$my_CPPFLAGS"
+ LIBS="$my_LIBS"
+@@ -840,7 +841,8 @@
+ problem_png=": Internal png detection logic error"
+ fi
+ fi],
+- [with_png="no"; problem_png=": png test error, see config.log"])
++ [with_png="no"; problem_png=": png test error, see config.log"],
++ [echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ AC_MSG_RESULT($with_png)
+ CPPFLAGS="$my_CPPFLAGS"
+ LIBS="$my_LIBS"
diff --git a/recipes/fvwm/fvwm_2.5.26.bb b/recipes/fvwm/fvwm_2.5.26.bb
new file mode 100644
index 0000000000..10677aea6a
--- /dev/null
+++ b/recipes/fvwm/fvwm_2.5.26.bb
@@ -0,0 +1,46 @@
+SECTION = "x11/wm"
+DESCRIPTION = "FVWM Window Manager"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxfixes libxpm xrandr xft libxml2 zlib libice libxau libxcb libxcursor libxdmcp libxrender libpng librsvg fontconfig libstroke"
+
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2 \
+ file://oe-configure.ac.patch;patch=1 \
+ file://upstream-configure.ac.patch;patch=1 \
+ file://acinclude.m4.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-xinerama --disable-bidi --disable-perllib \
+ --disable-gtk --without-gnome --without-imlib \
+ --disable-freetypetest --disable-fontconfigtest --disable-xfttest \
+ --disable-imlibtest --disable-sm \
+ "
+
+PACKAGES =+ "${PN}-perl"
+
+FILES_${PN}-dbg += " \
+ ${libexecdir}/${PN}/${PV}/.debug \
+ ${bindir}/${PN}-bug \
+"
+
+FILES_${PN}-dev += "${bindir}/${PN}-config"
+
+FILES_${PN}-perl = " \
+ ${bindir}/${PN}-convert-2.4 \
+ ${bindir}/${PN}-convert-2.6 \
+ ${bindir}/${PN}-menu* \
+ ${bindir}/${PN}-perllib \
+ ${libexecdir}/${PN}/${PV}/FvwmPerl \
+ ${libexecdir}/${PN}/${PV}/FvwmCommand.pm \
+ ${libexecdir}/${PN}/${PV}/FvwmConsoleC.pl \
+ ${libexecdir}/${PN}/${PV}/FvwmDebug \
+ ${libexecdir}/${PN}/${PV}/FvwmGtkDebug \
+ ${libexecdir}/${PN}/${PV}/FvwmTabs \
+ ${libexecdir}/${PN}/${PV}/FvwmWindowMenu \
+ ${datadir}/${PN}/FvwmScript-ComExample \
+ ${datadir}/${PN}/FvwmScript-Setup95 \
+ ${datadir}/${PN}/fvwm-script-setup95.pl \
+ ${datadir}/${PN}/fvwm-script-ComExample.pl \
+"
+