aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gabriel
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-07 10:41:22 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-07 10:42:32 +0200
commitb4c72a2368bd3939ca79bfda13bac01d8ea5fbcb (patch)
tree7584a7abfa8c518ddd0d3c0d011767c665f9d9c1 /recipes/gabriel
parent8658973a5624fc5af7d4a35b50adccad7d3bb0cc (diff)
downloadopenembedded-b4c72a2368bd3939ca79bfda13bac01d8ea5fbcb.tar.gz
gabriel[-native]: new recipe; proxy for remote dbus access
Diffstat (limited to 'recipes/gabriel')
-rw-r--r--recipes/gabriel/gabriel-native_svn.bb13
-rw-r--r--recipes/gabriel/gabriel_svn.bb14
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes/gabriel/gabriel-native_svn.bb b/recipes/gabriel/gabriel-native_svn.bb
new file mode 100644
index 0000000000..a98abb028e
--- /dev/null
+++ b/recipes/gabriel/gabriel-native_svn.bb
@@ -0,0 +1,13 @@
+require gabriel_svn.bb
+inherit native
+DEPENDS = "libssh-native glib-2.0-native dbus-native dbus-glib-native"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 src/gabriel ${DEPLOY_DIR_TOOLS}/gabriel-${PV}
+ rm -f ${DEPLOY_DIR_TOOLS}/gabriel
+ ln -sf ./gabriel-${PV} ${DEPLOY_DIR_TOOLS}/gabriel
+}
+
+
+addtask deploy before do_package after do_install
diff --git a/recipes/gabriel/gabriel_svn.bb b/recipes/gabriel/gabriel_svn.bb
new file mode 100644
index 0000000000..1449311f90
--- /dev/null
+++ b/recipes/gabriel/gabriel_svn.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Gabriel is a small utility to enable D-Bus clients to connect to a D-Bus \
+daemon running on a remote machine, through SSH. In simple words, gabriel is a proxy for \
+a dbus daemon running on a remote machine."
+LICENSE = "GPL"
+DEPENDS = "libssh glib-2.0 dbus glib-dbus"
+SECTION = "console/network"
+PV = "0.0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://gabriel.svn.sourceforge.net/svnroot/gabriel;module=gabriel;proto=https"
+S = "${WORKDIR}/gabriel"
+
+inherit autotools_stage
+
+RDEPENDS = "socat"