summaryrefslogtreecommitdiffstats
path: root/recipes/galago
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/galago
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/galago')
-rw-r--r--recipes/galago/eds-feed/disable-bonobo.patch62
-rw-r--r--recipes/galago/eds-feed_0.3.2.bb14
-rw-r--r--recipes/galago/files/no-check.patch15
-rw-r--r--recipes/galago/galago-daemon_0.3.4.bb14
-rw-r--r--recipes/galago/libgalago_0.3.3.bb17
5 files changed, 122 insertions, 0 deletions
diff --git a/recipes/galago/eds-feed/disable-bonobo.patch b/recipes/galago/eds-feed/disable-bonobo.patch
new file mode 100644
index 0000000000..3a2097877a
--- /dev/null
+++ b/recipes/galago/eds-feed/disable-bonobo.patch
@@ -0,0 +1,62 @@
+Index: eds-feed-0.3.2/configure.ac
+===================================================================
+--- eds-feed-0.3.2.orig/configure.ac 2005-08-28 19:11:39.000000000 +0000
++++ eds-feed-0.3.2/configure.ac 2005-12-16 09:22:10.000000000 +0000
+@@ -65,7 +65,7 @@
+ libxml-2.0)
+
+ # Check which version of eds we're using
+-PKG_CHECK_MODULES(EDS, libebook-1.2 >= 1.1.4 libedata-book-1.2 >= 1.1.4)
++PKG_CHECK_MODULES(EDS, libebook-1.2 >= 1.1.4)
+
+ PACKAGE_CFLAGS="$PACKAGE_CFLAGS $EDS_CFLAGS"
+ PACKAGE_LIBS="$PACKAGE_LIBS $EDS_LIBS"
+Index: eds-feed-0.3.2/src/main.c
+===================================================================
+--- eds-feed-0.3.2.orig/src/main.c 2005-08-21 07:26:02.000000000 +0000
++++ eds-feed-0.3.2/src/main.c 2005-12-16 09:24:38.000000000 +0000
+@@ -20,17 +20,11 @@
+ */
+ #include <glib.h>
+ #include <libgalago/galago.h>
+-#include <libedata-book/Evolution-DataServer-Addressbook.h>
+
+ #include <libebook/e-book.h>
+-#include <libedata-book/e-data-book-factory.h>
+-#include <bonobo/bonobo-main.h>
+
+ #include <string.h>
+
+-#define E_DATA_BOOK_FACTORY_OAF_ID \
+- "OAFIID:GNOME_Evolution_DataServer_BookFactory"
+-
+ static EBookView *book_view = NULL;
+ static EBook *book = NULL;
+ static gulong book_view_tag = 0;
+@@ -157,8 +151,8 @@
+ galago_person_set_photo(person, NULL);
+ else
+ {
+- galago_photo_new(person, (unsigned char *)ephoto->data,
+- ephoto->length);
++// galago_photo_new(person, (unsigned char *)ephoto->data,
++// ephoto->length);
+ }
+ }
+
+@@ -294,15 +288,6 @@
+
+ galago_core_set_exit_with_daemon(TRUE);
+
+- if (!bonobo_init_full(NULL, NULL, bonobo_activation_orb_get(),
+- CORBA_OBJECT_NIL, CORBA_OBJECT_NIL))
+- {
+- fprintf(stderr, "Unable to initialize bonobo.\n");
+- exit(1);
+- }
+-
+- bonobo_activate();
+-
+ setup_book_view();
+ setup_services();
+
diff --git a/recipes/galago/eds-feed_0.3.2.bb b/recipes/galago/eds-feed_0.3.2.bb
new file mode 100644
index 0000000000..59dc914eb2
--- /dev/null
+++ b/recipes/galago/eds-feed_0.3.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Galago linkage to the Evolution Data Server."
+HOMEPAGE = "http://www.galago-project.org/"
+LICENSE = "GPL"
+DEPENDS = "gettext libgalago dbus glib-2.0 eds-dbus"
+
+SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+ file://disable-bonobo.patch;patch=1"
+# file://no-check.patch;patch=1"
+#EXTRA_OECONF = "--disable-binreloc"
+
+FILES_${PN} += "${libdir}/galago/eds-feed"
+
+inherit autotools pkgconfig
+
diff --git a/recipes/galago/files/no-check.patch b/recipes/galago/files/no-check.patch
new file mode 100644
index 0000000000..89b0eafac7
--- /dev/null
+++ b/recipes/galago/files/no-check.patch
@@ -0,0 +1,15 @@
+--- /tmp/configure.ac 2005-09-08 21:38:49.316449440 +0200
++++ libgalago-0.3.3/configure.ac 2005-09-08 21:39:32.697854464 +0200
+@@ -198,11 +198,8 @@
+ dnl #
+ dnl # Check for Check
+ dnl #
+-AM_PATH_CHECK(, [have_check="yes"],
+-[
+- AC_MSG_WARN([Check not found; cannot run some unit tests])
+ have_check="no"
+-])
++
+
+ AM_CONDITIONAL(HAVE_CHECK, test "$have_check" = "yes")
+
diff --git a/recipes/galago/galago-daemon_0.3.4.bb b/recipes/galago/galago-daemon_0.3.4.bb
new file mode 100644
index 0000000000..243e42da4e
--- /dev/null
+++ b/recipes/galago/galago-daemon_0.3.4.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Galago is a desktop presence framework, designed to transmit presence information between programs."
+HOMEPAGE = "http://www.galago-project.org/"
+LICENSE = "GPL"
+DEPENDS = "gettext libgalago dbus glib-2.0"
+PR = "r1"
+
+SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+ file://no-check.patch;patch=1"
+EXTRA_OECONF = "--disable-binreloc"
+
+FILES_${PN} += "${datadir}/dbus-1/services/"
+
+inherit autotools pkgconfig
+
diff --git a/recipes/galago/libgalago_0.3.3.bb b/recipes/galago/libgalago_0.3.3.bb
new file mode 100644
index 0000000000..64064728b8
--- /dev/null
+++ b/recipes/galago/libgalago_0.3.3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Galago is a desktop presence framework, designed to transmit presence information between programs."
+HOMEPAGE = "http://www.galago-project.org/"
+LICENSE = "LGPL"
+DEPENDS = "gettext dbus glib-2.0"
+PR = "r1"
+
+
+SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
+ file://no-check.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ install -m 755 libgalago/.libs/libgalago.so.1.0.0 ${STAGING_LIBDIR}/libgalago.so
+}