aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gallery/gallery_1.5.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gallery/gallery_1.5.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gallery/gallery_1.5.5.bb')
-rw-r--r--recipes/gallery/gallery_1.5.5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gallery/gallery_1.5.5.bb b/recipes/gallery/gallery_1.5.5.bb
new file mode 100644
index 0000000000..14c7c0f4e0
--- /dev/null
+++ b/recipes/gallery/gallery_1.5.5.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "The Gallery v1 web image gallery"
+SECTION = "apps"
+LICENSE = "GPL"
+RDEPENDS = "apache2 modphp imagemagick jhead"
+PR = "r2"
+
+SRC_URI = "http://{SOURCEFORGE_MIRROR}/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
+
+S = "${WORKDIR}/gallery"
+
+inherit autotools
+
+HTTPCONF = "${sysconfdir}/apache2/httpd.conf"
+DEST_DIR = "${datadir}/apache2/htdocs/"
+
+#
+# don't list the albums as a file - it might get auto-deleted
+#
+FILES_${PN} = "${DEST_DIR}/gallery ${sysconfdir}/apache2/modules.d"
+
+
+# No configure step for gallery
+do_configure() {
+ :
+}
+
+# No compile step either
+do_compile() {
+ :
+}
+
+#
+do_install() {
+ mkdir -p ${D}/${DEST_DIR} ${D}${sysconfdir}/apache2/modules.d
+ cp -pPR ${S} ${D}/${DEST_DIR}
+ cp ${FILESDIR}/gallery.conf ${D}${sysconfdir}/apache2/modules.d/95_gallery.conf
+}
+
+# remove the gallery code, but not the albums!
+pkg_postrm_${PN}() {
+ rm -rf ${DEST_DIR}/gallery /${sysconfdir}/apache2/modules.d/95_gallery.conf
+}