aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gammu
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gammu
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gammu')
-rw-r--r--recipes/gammu/gammu_1.20.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/gammu/gammu_1.20.0.bb b/recipes/gammu/gammu_1.20.0.bb
new file mode 100644
index 0000000000..6cc864498a
--- /dev/null
+++ b/recipes/gammu/gammu_1.20.0.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+PR = "r1"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
+
+# it is CMake based but when inherit cmake it builds static binary/library
+inherit autotools pkgconfig
+
+do_configure() {
+ cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+# gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
+# Replace it by custom do_stage_append():
+do_stage_append () {
+ install -d ${PKG_CONFIG_DIR}
+ cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
+}
+
+PACKAGES =+ "libgammu"
+
+FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker"
+FILES_${PN}-dev += "${bindir}/gammu-config"
+FILES_libgammu = "${libdir}/libGammu.so.*"