summaryrefslogtreecommitdiffstats
path: root/recipes/gammu
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-06-12 14:17:42 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-06-12 14:17:42 +0000
commit50bb21e8041c91963cc6e057074e5d6e857acce5 (patch)
tree4ea015959bac5d3e74e0b10c2a3a28a145f92849 /recipes/gammu
parent649b44a943f5a2cca45b346b903e6cdee7d5ed21 (diff)
downloadopenembedded-50bb21e8041c91963cc6e057074e5d6e857acce5.tar.gz
gammu: Update to version 1.24.0.
Diffstat (limited to 'recipes/gammu')
-rw-r--r--recipes/gammu/gammu-1.24.0/findmysql.patch35
-rw-r--r--recipes/gammu/gammu_1.24.0.bb42
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/gammu/gammu-1.24.0/findmysql.patch b/recipes/gammu/gammu-1.24.0/findmysql.patch
new file mode 100644
index 0000000000..b6345b1bd0
--- /dev/null
+++ b/recipes/gammu/gammu-1.24.0/findmysql.patch
@@ -0,0 +1,35 @@
+Index: gammu-1.24.0/cmake/FindMySQL.cmake
+===================================================================
+--- gammu-1.24.0.orig/cmake/FindMySQL.cmake 2008-11-20 15:37:28.000000000 +0000
++++ gammu-1.24.0/cmake/FindMySQL.cmake 2009-06-12 12:18:06.000000000 +0000
+@@ -30,7 +30,7 @@
+ ARGS --include
+ OUTPUT_VARIABLE MY_TMP)
+
+- string(REGEX REPLACE "-I([^ ]*)( .*)?" "\\1" MY_TMP "${MY_TMP}")
++ string(REGEX REPLACE "-I([^ ]+)( .*)?" "\\1" MY_TMP "${MY_TMP}")
+
+ set(MYSQL_ADD_INCLUDE_DIR ${MY_TMP} CACHE FILEPATH INTERNAL)
+
+@@ -41,17 +41,19 @@
+
+ set(MYSQL_ADD_LIBRARIES "")
+
+- string(REGEX MATCHALL "-l[^ ]*" MYSQL_LIB_LIST "${MY_TMP}")
++ string(REGEX MATCHALL "(^| )-l[^ ]+" MYSQL_LIB_LIST "${MY_TMP}")
+ foreach(LIB ${MYSQL_LIB_LIST})
+ string(REGEX REPLACE "[ ]*-l([^ ]*)" "\\1" LIB "${LIB}")
++ message("${LIB}")
+ list(APPEND MYSQL_ADD_LIBRARIES "${LIB}")
+ endforeach(LIB ${MYSQL_LIBS})
+
+ set(MYSQL_ADD_LIBRARY_PATH "")
+
+- string(REGEX MATCHALL "-L[^ ]*" MYSQL_LIBDIR_LIST "${MY_TMP}")
++ string(REGEX MATCHALL "-L[^ ]+" MYSQL_LIBDIR_LIST "${MY_TMP}")
+ foreach(LIB ${MYSQL_LIBDIR_LIST})
+ string(REGEX REPLACE "[ ]*-L([^ ]*)" "\\1" LIB "${LIB}")
++ message("${LIB}")
+ list(APPEND MYSQL_ADD_LIBRARY_PATH "${LIB}")
+ endforeach(LIB ${MYSQL_LIBS})
+
diff --git a/recipes/gammu/gammu_1.24.0.bb b/recipes/gammu/gammu_1.24.0.bb
new file mode 100644
index 0000000000..56a1a91729
--- /dev/null
+++ b/recipes/gammu/gammu_1.24.0.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native python mysql"
+RDEPENDS_python-${PN} = "python-core"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+PR = "r0"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 \
+ file://findmysql.patch;patch=1"
+
+inherit distutils-common-base cmake
+
+PYTHON_DIR = "${@python_dir(d)}"
+
+do_configure() {
+ cd ${S}
+ sed -i 's@^cmake [^$]*\$@cmake -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_TARGET} $@' configure
+ sed -i 's@\${PYTHON_SITEDIR}@${libdir}/${PYTHON_DIR}/site-packages@g' python/gammu/CMakeLists.txt
+ ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+# gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
+# Replace it by custom do_stage_append():
+#do_stage_append () {
+# install -d ${PKG_CONFIG_DIR}
+# cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
+#}
+
+PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
+
+FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu"
+FILES_${PN}-smsd = "${bindir}/gammu-smsd*"
+FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${libdir}/python*/site-packages/gammu/.debug"
+FILES_libgammu = "${libdir}/libGammu.so.*"
+FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
+FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/gammu/*.??"