summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.2.2.inc
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/gcc/gcc-4.2.2.inc
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.2.2.inc')
-rw-r--r--recipes/gcc/gcc-4.2.2.inc110
1 files changed, 55 insertions, 55 deletions
diff --git a/recipes/gcc/gcc-4.2.2.inc b/recipes/gcc/gcc-4.2.2.inc
index e343137c98..2a5334a30a 100644
--- a/recipes/gcc/gcc-4.2.2.inc
+++ b/recipes/gcc/gcc-4.2.2.inc
@@ -7,73 +7,73 @@ NATIVEDEPS = "mpfr-native gmp-native"
INC_PR = "r16"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
- file://100-uclibc-conf.patch;apply=yes \
- file://103-uclibc-conf-noupstream.patch;apply=yes \
- file://200-uclibc-locale.patch;apply=yes \
- file://203-uclibc-locale-no__x.patch;apply=yes \
- file://204-uclibc-locale-wchar_fix.patch;apply=yes \
- file://205-uclibc-locale-update.patch;apply=yes \
- file://300-libstdc++-pic.patch;apply=yes \
- file://301-missing-execinfo_h.patch;apply=yes \
- file://302-c99-snprintf.patch;apply=yes \
- file://303-c99-complex-ugly-hack.patch;apply=yes \
- file://304-index_macro.patch;apply=yes \
- file://305-libmudflap-susv3-legacy.patch;apply=yes \
- file://306-libstdc++-namespace.patch;apply=yes \
- file://307-locale_facets.patch;apply=yes \
- file://402-libbackend_dep_gcov-iov.h.patch;apply=yes \
- file://602-sdk-libstdc++-includes.patch;apply=yes \
- file://740-sh-pr24836.patch;apply=yes \
- file://800-arm-bigendian.patch;apply=yes \
- file://801-arm-bigendian-eabi.patch;apply=yes \
- file://904-flatten-switch-stmt-00.patch;apply=yes \
- file://arm-nolibfloat.patch;apply=yes \
- file://arm-softfloat.patch;apply=yes \
- file://gcc41-configure.in.patch;apply=yes \
- file://arm-thumb.patch;apply=yes \
- file://arm-thumb-cache.patch;apply=yes \
- file://zecke-xgcc-cpp.patch;apply=yes \
- file://unbreak-armv4t.patch;apply=yes \
- file://cache-amnesia.patch;apply=yes \
- file://gfortran.patch;apply=yes \
- file://gcc-4.0.2-e300c2c3.patch;apply=yes \
- file://pr34130.patch;apply=yes \
- file://fortran-static-linking.patch;apply=yes \
- file://intermask-bigendian.patch;apply=yes \
+ file://100-uclibc-conf.patch \
+ file://103-uclibc-conf-noupstream.patch \
+ file://200-uclibc-locale.patch \
+ file://203-uclibc-locale-no__x.patch \
+ file://204-uclibc-locale-wchar_fix.patch \
+ file://205-uclibc-locale-update.patch \
+ file://300-libstdc++-pic.patch \
+ file://301-missing-execinfo_h.patch \
+ file://302-c99-snprintf.patch \
+ file://303-c99-complex-ugly-hack.patch \
+ file://304-index_macro.patch \
+ file://305-libmudflap-susv3-legacy.patch \
+ file://306-libstdc++-namespace.patch \
+ file://307-locale_facets.patch \
+ file://402-libbackend_dep_gcov-iov.h.patch \
+ file://602-sdk-libstdc++-includes.patch \
+ file://740-sh-pr24836.patch \
+ file://800-arm-bigendian.patch \
+ file://801-arm-bigendian-eabi.patch \
+ file://904-flatten-switch-stmt-00.patch \
+ file://arm-nolibfloat.patch \
+ file://arm-softfloat.patch \
+ file://gcc41-configure.in.patch \
+ file://arm-thumb.patch \
+ file://arm-thumb-cache.patch \
+ file://zecke-xgcc-cpp.patch \
+ file://unbreak-armv4t.patch \
+ file://cache-amnesia.patch \
+ file://gfortran.patch \
+ file://gcc-4.0.2-e300c2c3.patch \
+ file://pr34130.patch \
+ file://fortran-static-linking.patch \
+ file://intermask-bigendian.patch \
"
SRC_URI_append_avr32 = " \
- file://gcc-4.2.2.atmel.1.0.8.patch.bz2;apply=yes \
- file://901-avr32-fix-no-cond-exec-before-reload.patch;apply=yes \
- file://902-avr32-fix-sync-insn-instructions.patch;apply=yes \
- file://903-avr32-fix-removal-of-redundant-cast-operations.patch;apply=yes \
+ file://gcc-4.2.2.atmel.1.0.8.patch.bz2 \
+ file://901-avr32-fix-no-cond-exec-before-reload.patch \
+ file://902-avr32-fix-sync-insn-instructions.patch \
+ file://903-avr32-fix-removal-of-redundant-cast-operations.patch \
"
SRC_URI_append_ep93xx = " \
- file://arm-crunch-saveregs.patch;apply=yes \
- file://arm-crunch-20000320.patch;apply=yes \
- file://arm-crunch-compare.patch;apply=yes \
- file://arm-crunch-compare-unordered.patch;apply=yes \
- file://arm-crunch-compare-geu.patch;apply=yes \
- file://arm-crunch-eabi-ieee754.patch;apply=yes \
- file://arm-crunch-eabi-ieee754-div.patch;apply=yes \
- file://arm-crunch-64bit-disable0.patch;apply=yes \
- file://arm-crunch-offset.patch;apply=yes \
- file://arm-crunch-fp_consts.patch;apply=yes \
- file://arm-crunch-neg2.patch;apply=yes \
- file://arm-crunch-predicates3.patch;apply=yes \
- file://arm-crunch-cfcvtds-disable.patch;apply=yes \
- file://arm-crunch-floatsi-disable.patch;apply=yes \
- file://arm-crunch-truncsi-disable.patch;apply=yes \
- file://arm-crunch-cfcvt64-disable.patch;apply=yes \
- file://arm-crunch-cirrus-bugfixes.patch;apply=yes \
+ file://arm-crunch-saveregs.patch \
+ file://arm-crunch-20000320.patch \
+ file://arm-crunch-compare.patch \
+ file://arm-crunch-compare-unordered.patch \
+ file://arm-crunch-compare-geu.patch \
+ file://arm-crunch-eabi-ieee754.patch \
+ file://arm-crunch-eabi-ieee754-div.patch \
+ file://arm-crunch-64bit-disable0.patch \
+ file://arm-crunch-offset.patch \
+ file://arm-crunch-fp_consts.patch \
+ file://arm-crunch-neg2.patch \
+ file://arm-crunch-predicates3.patch \
+ file://arm-crunch-cfcvtds-disable.patch \
+ file://arm-crunch-floatsi-disable.patch \
+ file://arm-crunch-truncsi-disable.patch \
+ file://arm-crunch-cfcvt64-disable.patch \
+ file://arm-crunch-cirrus-bugfixes.patch \
"
PACKAGE_ARCH_ep93xx = "${MACHINE_ARCH}"
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;apply=yes "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch "
# Language Overrides
FORTRAN = ""