aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.2.4
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-06 10:40:01 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-06 10:40:01 -0700
commit457d5b9818e21492a1425d8b6811cf57702394eb (patch)
treec009a8b8ab3d608399028630e4daf0d8d487d29f /recipes/gcc/gcc-4.2.4
parentc070de32d40dd561b63de5b4f41baa3cf822ef5b (diff)
downloadopenembedded-457d5b9818e21492a1425d8b6811cf57702394eb.tar.gz
gcc-4.2.4: Fix libstdc++ build failures with new sysrooted staging.
* New sysrooted staging exposed few problems in GCC configury which were latent previously. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.2.4')
-rw-r--r--recipes/gcc/gcc-4.2.4/libstdc++-hack-libtool-remove-lstdc++.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.2.4/libstdc++-hack-libtool-remove-lstdc++.patch b/recipes/gcc/gcc-4.2.4/libstdc++-hack-libtool-remove-lstdc++.patch
new file mode 100644
index 0000000000..0987efab2b
--- /dev/null
+++ b/recipes/gcc/gcc-4.2.4/libstdc++-hack-libtool-remove-lstdc++.patch
@@ -0,0 +1,18 @@
+This is a hacked backport of backport http://gcc.gnu.org/bugzilla/show_bug.cgi?id=35942
+which is in no way similar in implementation but achieves same results. libtool in
+gcc 4.2 does not have postdeps_CXX separated out so it can not be used.
+
+-Khem
+
+Index: gcc-4.2.4/Makefile.in
+===================================================================
+--- gcc-4.2.4.orig/Makefile.in 2010-06-06 09:49:36.724619615 -0700
++++ gcc-4.2.4/Makefile.in 2010-06-06 10:03:59.092090624 -0700
+@@ -33586,6 +33586,7 @@ all-target-libstdc++-v3: configure-targe
+ @: $(MAKE); $(unstage)
+ @r=`${PWD_COMMAND}`; export r; \
+ s=`cd $(srcdir); ${PWD_COMMAND}`; export s; \
++ sed -i 's|postdeps=\"-lstdc++|postdeps=\"|' $(TARGET_SUBDIR)/libstdc++-v3/libtool; \
+ $(RAW_CXX_TARGET_EXPORTS) \
+ (cd $(TARGET_SUBDIR)/libstdc++-v3 && \
+ $(MAKE) $(TARGET_FLAGS_TO_PASS) 'CXX=$$(RAW_CXX_FOR_TARGET)' 'CXX_FOR_TARGET=$$(RAW_CXX_FOR_TARGET)' $(TARGET-target-libstdc++-v3))