aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch')
-rw-r--r--recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch b/recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
new file mode 100644
index 0000000000..f86ee09942
--- /dev/null
+++ b/recipes/gcc/gcc-4.3.3/debian/deb-protoize.dpatch
@@ -0,0 +1,47 @@
+#! /bin/sh -e
+
+# DP: build protoize/unprotoize binaries
+
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch) patch $pdir -f --no-backup-if-mismatch -p0 < $0;;
+ -unpatch) patch $pdir -f --no-backup-if-mismatch -R -p0 < $0;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- gcc/Makefile.in.orig 2007-09-06 21:31:39.864036975 +0200
++++ gcc/Makefile.in 2007-09-06 21:33:57.836118252 +0200
+@@ -137,7 +137,7 @@
+
+ # Selection of languages to be made.
+ CONFIG_LANGUAGES = @all_selected_languages@
+-LANGUAGES = c gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
++LANGUAGES = c proto gcov$(exeext) gcov-dump$(exeext) $(CONFIG_LANGUAGES)
+
+ # Various ways of specifying flags for compilations:
+ # CFLAGS is for the user to override to, e.g., do a cross build with -O2.
+@@ -3280,14 +3280,14 @@
+ protoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) $(SYSTEM_H) \
+ coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
+ (SHLIB_LINK='$(SHLIB_LINK)'; \
+- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
+ $(DRIVER_DEFINES) \
+ $(srcdir)/protoize.c $(OUTPUT_OPTION))
+
+ unprotoize.o: protoize.c $(srcdir)/../include/getopt.h $(CONFIG_H) \
+ $(SYSTEM_H) coretypes.h $(TM_H) Makefile version.h cppdefault.h intl.h
+ (SHLIB_LINK='$(SHLIB_LINK)'; \
+- $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++ $(CC) -c -DUNPROTOIZE $(ALL_CFLAGS) $(ALL_CPPFLAGS) -Wno-error \
+ $(DRIVER_DEFINES) \
+ $(srcdir)/protoize.c $(OUTPUT_OPTION))
+