summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-05-17 00:08:37 -0700
committerKhem Raj <raj.khem@gmail.com>2010-05-17 00:11:35 -0700
commitb362ce8d2330d6d8b2498ecbfe5f9ad8b183df68 (patch)
treedcdd643c245bd7f5c0874c21d964726778d930f7 /recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
parent15f7ad62121a4f8b1fee2c9d258edcfd569afb8b (diff)
downloadopenembedded-b362ce8d2330d6d8b2498ecbfe5f9ad8b183df68.tar.gz
gcc-4.3.3: Fix spurious leak of build sysroot into .la files.
* ldflags were being passed unnessarily so set LDFLAGS to nothing in Makefile.tpl and regenerate top level Makefile.in * Divide the patches individually earlier the patches were combined into one big patch * Shuffle the order of patches. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch')
-rw-r--r--recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch b/recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
index a7722cbfc4..d915b911ba 100644
--- a/recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
+++ b/recipes/gcc/gcc-4.3.3/zecke-xgcc-cpp.patch
@@ -2,27 +2,27 @@ upstream: n/a
comment: Use the preprocessor we have just compiled instead the one of
the system. There might be incompabilities between us and them.
-Index: gcc-4.3.1/Makefile.in
+Index: gcc-4.3.3/Makefile.in
===================================================================
---- gcc-4.3.1.orig/Makefile.in 2008-08-19 01:09:56.000000000 -0700
-+++ gcc-4.3.1/Makefile.in 2008-08-19 01:13:27.000000000 -0700
-@@ -204,6 +204,7 @@
+--- gcc-4.3.3.orig/Makefile.in 2010-05-16 17:27:06.000000000 -0700
++++ gcc-4.3.3/Makefile.in 2010-05-16 18:50:32.363015133 -0700
+@@ -204,6 +204,7 @@ BASE_TARGET_EXPORTS = \
AR="$(AR_FOR_TARGET)"; export AR; \
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
- CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
-Index: gcc-4.3.1/Makefile.tpl
+Index: gcc-4.3.3/Makefile.tpl
===================================================================
---- gcc-4.3.1.orig/Makefile.tpl 2008-08-21 00:07:58.000000000 -0700
-+++ gcc-4.3.1/Makefile.tpl 2008-08-21 00:09:52.000000000 -0700
-@@ -223,6 +223,7 @@
+--- gcc-4.3.3.orig/Makefile.tpl 2010-05-16 17:27:06.000000000 -0700
++++ gcc-4.3.3/Makefile.tpl 2010-05-16 18:49:57.221575513 -0700
+@@ -207,6 +207,7 @@ BASE_TARGET_EXPORTS = \
AR="$(AR_FOR_TARGET)"; export AR; \
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET)"; export CC; \
+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
- CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \