aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
commit293b05335ab540c4c8402e0a5caf2886b786a318 (patch)
tree11e5a7c2dce338058f150e08d1ff47c9d4d8eccd /recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch
parent1ee2156592ba17f64f3c9b8970285a259730b871 (diff)
parente9aacc4ce4784c91cb4908145b8fb7b3ec8aa6e0 (diff)
downloadopenembedded-293b05335ab540c4c8402e0a5caf2886b786a318.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
Conflicts: recipes/linux/linux-openmoko-devel_git.bb recipes/openmoko-3rdparty/pisi_0.5.2.bb recipes/openmoko-3rdparty/pisi_0.5.3.bb recipes/openmoko-3rdparty/pisi_0.5.bb recipes/uclibc/uclibc_nptl.bb
Diffstat (limited to 'recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch')
-rw-r--r--recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch b/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..348c77006f
--- /dev/null
+++ b/recipes/gcc/gcc-4.5.0/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+Index: gcc-4.5+svnr155514/libgfortran/configure
+===================================================================
+--- gcc-4.5+svnr155514.orig/libgfortran/configure 2009-12-29 22:02:01.000000000 -0800
++++ gcc-4.5+svnr155514/libgfortran/configure 2009-12-30 08:12:40.889091657 -0800
+@@ -11655,7 +11655,7 @@ CC="$lt_save_CC"
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${ac_fc_srcext-f}
+ ac_compile='$FC -c $FCFLAGS $ac_fcflags_srcext conftest.$ac_ext >&5'
+ ac_link='$FC -o conftest$ac_exeext $FCFLAGS $LDFLAGS $ac_fcflags_srcext conftest.$ac_ext $LIBS >&5'
+Index: gcc-4.5+svnr155514/libgfortran/configure.ac
+===================================================================
+--- gcc-4.5+svnr155514.orig/libgfortran/configure.ac 2009-12-29 22:02:01.000000000 -0800
++++ gcc-4.5+svnr155514/libgfortran/configure.ac 2009-12-30 08:12:13.453094218 -0800
+@@ -187,7 +187,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets