summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-07 19:56:19 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-07 19:59:20 -0700
commit48b5a0e69d868a069c1b6fc4605ed0e281ee07af (patch)
tree149e5f9e5846c8650fb13034bab85fc777ede457 /recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
parentf6b09dcb6000ca31219281bb6abc060edf9528ce (diff)
downloadopenembedded-48b5a0e69d868a069c1b6fc4605ed0e281ee07af.tar.gz
gcc-4.5: Fix libstdc++ build for ARM
* This patch makes sure that __cxa_end_cleanup is emitted in .text section. * Bump SRCREV to latest Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.5/gcc-flags-for-build.patch')
-rw-r--r--recipes/gcc/gcc-4.5/gcc-flags-for-build.patch58
1 files changed, 29 insertions, 29 deletions
diff --git a/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
index 905152d430..510c462e6b 100644
--- a/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
+++ b/recipes/gcc/gcc-4.5/gcc-flags-for-build.patch
@@ -1,7 +1,7 @@
Index: gcc-4.5/Makefile.def
===================================================================
---- gcc-4.5.orig/Makefile.def 2010-05-30 20:32:58.000000000 -0700
-+++ gcc-4.5/Makefile.def 2010-05-30 22:40:11.810599683 -0700
+--- gcc-4.5.orig/Makefile.def 2010-06-04 23:21:43.000000000 -0700
++++ gcc-4.5/Makefile.def 2010-06-07 18:29:45.867493975 -0700
@@ -240,6 +240,7 @@ flags_to_pass = { flag= AWK ; };
flags_to_pass = { flag= BISON ; };
flags_to_pass = { flag= CC_FOR_BUILD ; };
@@ -12,8 +12,8 @@ Index: gcc-4.5/Makefile.def
flags_to_pass = { flag= FLEX ; };
Index: gcc-4.5/gcc/Makefile.in
===================================================================
---- gcc-4.5.orig/gcc/Makefile.in 2010-05-30 20:30:34.000000000 -0700
-+++ gcc-4.5/gcc/Makefile.in 2010-05-30 22:40:11.820599836 -0700
+--- gcc-4.5.orig/gcc/Makefile.in 2010-06-04 23:20:06.000000000 -0700
++++ gcc-4.5/gcc/Makefile.in 2010-06-07 18:29:45.877491615 -0700
@@ -762,7 +762,7 @@ BUILD_LINKERFLAGS = $(BUILD_CFLAGS)
# Native linker and preprocessor flags. For x-fragment overrides.
@@ -25,9 +25,9 @@ Index: gcc-4.5/gcc/Makefile.in
GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')
Index: gcc-4.5/gcc/configure.ac
===================================================================
---- gcc-4.5.orig/gcc/configure.ac 2010-05-30 22:39:14.000000000 -0700
-+++ gcc-4.5/gcc/configure.ac 2010-05-30 22:40:11.820599836 -0700
-@@ -1782,16 +1782,18 @@ AC_SUBST(inhibit_libc)
+--- gcc-4.5.orig/gcc/configure.ac 2010-06-07 17:45:41.000000000 -0700
++++ gcc-4.5/gcc/configure.ac 2010-06-07 18:29:45.877491615 -0700
+@@ -1798,16 +1798,18 @@ AC_SUBST(inhibit_libc)
# Also, we cannot run fixincludes.
# These are the normal (build=host) settings:
@@ -52,8 +52,8 @@ Index: gcc-4.5/gcc/configure.ac
# Expand extra_headers to include complete path.
Index: gcc-4.5/Makefile.in
===================================================================
---- gcc-4.5.orig/Makefile.in 2010-05-30 20:32:58.000000000 -0700
-+++ gcc-4.5/Makefile.in 2010-05-30 22:40:11.830627507 -0700
+--- gcc-4.5.orig/Makefile.in 2010-06-04 23:21:43.000000000 -0700
++++ gcc-4.5/Makefile.in 2010-06-07 18:29:45.887501058 -0700
@@ -333,6 +333,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
@@ -72,8 +72,8 @@ Index: gcc-4.5/Makefile.in
"FLEX=$(FLEX)" \
Index: gcc-4.5/gcc/configure
===================================================================
---- gcc-4.5.orig/gcc/configure 2010-05-30 22:39:14.000000000 -0700
-+++ gcc-4.5/gcc/configure 2010-05-30 22:42:23.488119238 -0700
+--- gcc-4.5.orig/gcc/configure 2010-06-07 17:45:41.000000000 -0700
++++ gcc-4.5/gcc/configure 2010-06-07 18:30:48.917502927 -0700
@@ -705,6 +705,7 @@ SED
LIBTOOL
collect2
@@ -82,7 +82,7 @@ Index: gcc-4.5/gcc/configure
BUILD_LDFLAGS
BUILD_CFLAGS
CC_FOR_BUILD
-@@ -10927,6 +10928,7 @@ fi
+@@ -10980,6 +10981,7 @@ fi
CC_FOR_BUILD='$(CC)'
BUILD_CFLAGS='$(ALL_CFLAGS)'
BUILD_LDFLAGS='$(LDFLAGS)'
@@ -90,7 +90,7 @@ Index: gcc-4.5/gcc/configure
STMP_FIXINC=stmp-fixinc
# And these apply if build != host, or we are generating coverage data
-@@ -10934,6 +10936,7 @@ if test x$build != x$host || test "x$cov
+@@ -10987,6 +10989,7 @@ if test x$build != x$host || test "x$cov
then
BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)'
BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)'
@@ -98,28 +98,28 @@ Index: gcc-4.5/gcc/configure
fi
# Expand extra_headers to include complete path.
-@@ -17053,7 +17056,7 @@ else
+@@ -17106,7 +17109,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17056 "configure"
-+#line 17059 "configure"
+-#line 17109 "configure"
++#line 17112 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -17159,7 +17162,7 @@ else
+@@ -17212,7 +17215,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 17162 "configure"
-+#line 17165 "configure"
+-#line 17215 "configure"
++#line 17218 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
Index: gcc-4.5/Makefile.tpl
===================================================================
---- gcc-4.5.orig/Makefile.tpl 2010-05-30 20:32:58.000000000 -0700
-+++ gcc-4.5/Makefile.tpl 2010-05-30 22:40:11.840621166 -0700
+--- gcc-4.5.orig/Makefile.tpl 2010-06-04 23:21:43.000000000 -0700
++++ gcc-4.5/Makefile.tpl 2010-06-07 18:29:45.897539904 -0700
@@ -336,6 +336,7 @@ AR_FOR_BUILD = @AR_FOR_BUILD@
AS_FOR_BUILD = @AS_FOR_BUILD@
CC_FOR_BUILD = @CC_FOR_BUILD@
@@ -130,8 +130,8 @@ Index: gcc-4.5/Makefile.tpl
DLLTOOL_FOR_BUILD = @DLLTOOL_FOR_BUILD@
Index: gcc-4.5/configure
===================================================================
---- gcc-4.5.orig/configure 2010-05-30 22:39:13.018100422 -0700
-+++ gcc-4.5/configure 2010-05-30 22:40:11.840621166 -0700
+--- gcc-4.5.orig/configure 2010-06-07 17:45:40.329993062 -0700
++++ gcc-4.5/configure 2010-06-07 18:29:45.897539904 -0700
@@ -651,6 +651,7 @@ GCJ_FOR_BUILD
DLLTOOL_FOR_BUILD
CXX_FOR_BUILD
@@ -140,7 +140,7 @@ Index: gcc-4.5/configure
CFLAGS_FOR_BUILD
CC_FOR_BUILD
AS_FOR_BUILD
-@@ -7973,6 +7974,7 @@ esac
+@@ -8027,6 +8028,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -148,7 +148,7 @@ Index: gcc-4.5/configure
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -8052,6 +8054,7 @@ done
+@@ -8106,6 +8108,7 @@ done
@@ -158,9 +158,9 @@ Index: gcc-4.5/configure
# programs in objdir.
Index: gcc-4.5/configure.ac
===================================================================
---- gcc-4.5.orig/configure.ac 2010-05-30 22:39:12.000000000 -0700
-+++ gcc-4.5/configure.ac 2010-05-30 22:40:11.840621166 -0700
-@@ -3061,6 +3061,7 @@ esac
+--- gcc-4.5.orig/configure.ac 2010-06-07 17:45:40.000000000 -0700
++++ gcc-4.5/configure.ac 2010-06-07 18:29:45.897539904 -0700
+@@ -3081,6 +3081,7 @@ esac
# our build compiler if desired.
if test x"${build}" = x"${host}" ; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
@@ -168,7 +168,7 @@ Index: gcc-4.5/configure.ac
CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
fi
-@@ -3127,6 +3128,7 @@ AC_SUBST(AR_FOR_BUILD)
+@@ -3147,6 +3148,7 @@ AC_SUBST(AR_FOR_BUILD)
AC_SUBST(AS_FOR_BUILD)
AC_SUBST(CC_FOR_BUILD)
AC_SUBST(CFLAGS_FOR_BUILD)