summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-05-31 13:25:08 -0700
committerKhem Raj <raj.khem@gmail.com>2010-05-31 13:25:08 -0700
commitb477024589c2a7cae769783a8dccadd47baf3674 (patch)
treedc749ea247e5717fdca63418780b2bff6fb02be5 /recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
parent55f3c701b2d748e935af226fc4b4e987835fa03f (diff)
downloadopenembedded-b477024589c2a7cae769783a8dccadd47baf3674.tar.gz
gcc-4.5: rename 4.5.0 to 4.5 and update to latest svn revision.
* GCC 4.5.0 has issues with arm that the resulting root file system is not bootable. These are fixed upstream which would become 4.5.1 so rename the recipes to 4.5 and use the svn revision to get the latest branch snapshot. * If some one wants to use it then it could be chosen by setting PREFERRRED_VERSION = "4.5" Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch')
-rw-r--r--recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch b/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
new file mode 100644
index 0000000000..a7722cbfc4
--- /dev/null
+++ b/recipes/gcc/gcc-4.5/zecke-xgcc-cpp.patch
@@ -0,0 +1,28 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
+Index: gcc-4.3.1/Makefile.in
+===================================================================
+--- gcc-4.3.1.orig/Makefile.in 2008-08-19 01:09:56.000000000 -0700
++++ gcc-4.3.1/Makefile.in 2008-08-19 01:13:27.000000000 -0700
+@@ -204,6 +204,7 @@
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+Index: gcc-4.3.1/Makefile.tpl
+===================================================================
+--- gcc-4.3.1.orig/Makefile.tpl 2008-08-21 00:07:58.000000000 -0700
++++ gcc-4.3.1/Makefile.tpl 2008-08-21 00:09:52.000000000 -0700
+@@ -223,6 +223,7 @@
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET)"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET) $(SYSROOT_CFLAGS_FOR_TARGET) $(DEBUG_PREFIX_CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \