aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-cross-sdk_4.5.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-05-31 13:25:08 -0700
committerKhem Raj <raj.khem@gmail.com>2010-05-31 13:25:08 -0700
commitb477024589c2a7cae769783a8dccadd47baf3674 (patch)
treedc749ea247e5717fdca63418780b2bff6fb02be5 /recipes/gcc/gcc-cross-sdk_4.5.bb
parent55f3c701b2d748e935af226fc4b4e987835fa03f (diff)
downloadopenembedded-b477024589c2a7cae769783a8dccadd47baf3674.tar.gz
gcc-4.5: rename 4.5.0 to 4.5 and update to latest svn revision.
* GCC 4.5.0 has issues with arm that the resulting root file system is not bootable. These are fixed upstream which would become 4.5.1 so rename the recipes to 4.5 and use the svn revision to get the latest branch snapshot. * If some one wants to use it then it could be chosen by setting PREFERRRED_VERSION = "4.5" Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-cross-sdk_4.5.bb')
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.5.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-cross-sdk_4.5.bb b/recipes/gcc/gcc-cross-sdk_4.5.bb
new file mode 100644
index 0000000000..a316cd282e
--- /dev/null
+++ b/recipes/gcc/gcc-cross-sdk_4.5.bb
@@ -0,0 +1,10 @@
+PR = "r2"
+
+inherit sdk
+
+require gcc-${PV}.inc
+require gcc-cross-sdk.inc
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"