summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-csl-arm-2007q3.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gcc/gcc-csl-arm-2007q3.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gcc/gcc-csl-arm-2007q3.inc')
-rw-r--r--recipes/gcc/gcc-csl-arm-2007q3.inc52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-csl-arm-2007q3.inc b/recipes/gcc/gcc-csl-arm-2007q3.inc
new file mode 100644
index 0000000000..a3da6c9ca3
--- /dev/null
+++ b/recipes/gcc/gcc-csl-arm-2007q3.inc
@@ -0,0 +1,52 @@
+require gcc-common.inc
+
+BINV = "4.2.1"
+PV = "4.2.1+csl-arm-2007q3-53"
+
+FILESPATH = "${FILE_DIRNAME}/gcc-csl-arm-2007q3:${FILE_DIRNAME}/gcc-csl-arm"
+
+SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2007q3-53-arm-none-eabi.src.tar.bz2 \
+ file://gcc-new-makeinfo.patch;patch=1 \
+# file://100-uclibc-conf.patch;patch=1 \
+# file://103-uclibc-conf-noupstream.patch;patch=1 \
+# file://200-uclibc-locale.patch;patch=1 \
+# file://203-uclibc-locale-no__x.patch;patch=1 \
+# file://204-uclibc-locale-wchar_fix.patch;patch=1 \
+# file://205-uclibc-locale-update.patch;patch=1 \
+# file://300-libstdc++-pic.patch;patch=1 \
+# file://302-c99-snprintf.patch;patch=1 \
+# file://303-c99-complex-ugly-hack.patch;patch=1 \
+# file://304-index_macro.patch;patch=1 \
+# file://305-libmudflap-susv3-legacy.patch;patch=1 \
+# file://306-libstdc++-namespace.patch;patch=1 \
+# file://307-locale_facets.patch;patch=1 \
+# file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
+# file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://arm-nolibfloat.patch;patch=1 \
+ file://arm-softfloat.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
+# file://gfortran.patch;patch=1 \
+# file://fortran-static-linking.patch;patch=1 \
+# file://gcc-configure-no-fortran.patch;patch=1;pnum=1 \
+# file://gcc-new-makeinfo.patch;patch=1 \
+ file://gcc-Os-fix.diff;patch=1 \
+"
+
+
+S = "${WORKDIR}/gcc-4.2"
+
+do_unpack2() {
+ cd ${WORKDIR}
+ tar -xvjf ./arm-2007q3-53-arm-none-eabi/gcc-2007q3-53.tar.bz2
+}
+
+# Language Overrides
+FORTRAN = ""
+#FORTRAN_linux-gnueabi = ",fortran"
+#JAVA = ",java"
+
+EXTRA_OECONF_BASE = "--enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
+ARM_INSTRUCTION_SET = "arm"
+
+addtask unpack2 after do_unpack before do_patch