summaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
committerKhem Raj <raj.khem@gmail.com>2009-04-06 12:16:23 -0700
commit877fed8078d379d213290b791a8a1282867f5061 (patch)
tree7ff5220fd262e343cc3b70634b41771d14580cdd /recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
parentfe6822f3e85d5b14586d747c72b4e0395d981ea9 (diff)
downloadopenembedded-877fed8078d379d213290b791a8a1282867f5061.tar.gz
gcc-svn: Add recipe to build bleeding edge gcc.
Diffstat (limited to 'recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch')
-rw-r--r--recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch b/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..b3d38ad983
--- /dev/null
+++ b/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets