aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:27:59 +0200
committermd <md@freiheit.com>2009-05-27 21:51:00 +0200
commit173ca78f2eebe33896407ef00b1391d8b205a01f (patch)
tree3b0128bbb6f4a88b144b40e94580001752b99c05 /recipes/gcc
parent207d01941323a39017f3de3f9ad83177b6df481d (diff)
downloadopenembedded-173ca78f2eebe33896407ef00b1391d8b205a01f.tar.gz
gcc: made sure that no unsubstituted @LDFLAGS@ is left in the generated Makefiles
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-configure-common.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-configure-common.inc b/recipes/gcc/gcc-configure-common.inc
index ee5784afc3..9363585de1 100644
--- a/recipes/gcc/gcc-configure-common.inc
+++ b/recipes/gcc/gcc-configure-common.inc
@@ -89,4 +89,7 @@ do_configure () {
echo "#define STANDARD_INCLUDE_DIR \"${layout_includedir}\"" >> ${S}/gcc/defaults.h
oe_runconf
+
+ # make sure that no @LDFLAG@ is left in the generated Makefile
+ sed -i "s/@LDFLAGS@//g" ${B}/Makefile
}