aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-11-25 14:47:58 -0800
committerKhem Raj <raj.khem@gmail.com>2010-11-25 14:47:58 -0800
commit3ad1829daa1466b40f8569d9299ab951f2f679a7 (patch)
tree20d6c781220367a8f37e337031f43c7df8810a6d /recipes/gcc
parentf97aeb1d04686cd532b4b013b47002913695ea8f (diff)
downloadopenembedded-3ad1829daa1466b40f8569d9299ab951f2f679a7.tar.gz
gcc-configure-sdk: Handle hardcoded /usr/include
This does not work for distros like micro who use a flattened tree structure for root file system Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-configure-sdk.inc8
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.0.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.5.bb2
15 files changed, 22 insertions, 14 deletions
diff --git a/recipes/gcc/gcc-configure-sdk.inc b/recipes/gcc/gcc-configure-sdk.inc
index c8fae11413..7210d2b05b 100644
--- a/recipes/gcc/gcc-configure-sdk.inc
+++ b/recipes/gcc/gcc-configure-sdk.inc
@@ -44,6 +44,14 @@ do_configure () {
sed -i 's/^\(HOST_LIBELFLIBS =\) \(.*\)$/\1 -Wl,-Bstatic \2 -Wl,-Bdynamic/' ${S}/Makefile.in
(cd ${S} && gnu-configize) || die "failure running gnu-configize"
+ # gcc assumes ${sysroot}/usr to be prefix on linux targets
+ # but we have distro option to flatten out the tree and micro
+ # uses root file system without leading /usr so we need to
+ # teach gcc configure to look in correct include paths
+ # unfortunately there is no configure knob to indicate this
+ # to configury hence the sed :(
+ sed -i 's:/usr/include:${target_includedir}:g' ${S}/gcc/configure.ac
+ sed -i 's:/usr/include:${target_includedir}:g' ${S}/gcc/configure
oe_runconf
}
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.0.bb b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
index 9aa6a56d7e..24c76b54dc 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
@@ -1,5 +1,5 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.1.bb b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
index 26eb80b8b0..7ea943e310 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.2.bb b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
index 2475f3efd8..b1525b3ba6 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.2.bb b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
index eb30315a62..4ec237bbfb 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.3.bb b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
index fbbfbcece3..62de382797 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.4.bb b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
index 28cdbb73a2..86ffc251ac 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.1.bb b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
index fbbfbcece3..62de382797 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.2.bb b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
index fbbfbcece3..62de382797 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.3.bb b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
index 62de382797..82bd95ea9f 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.4.bb b/recipes/gcc/gcc-cross-sdk_4.3.4.bb
index 1a2ed67342..fbbfbcece3 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.4.bb
@@ -1,4 +1,4 @@
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.4.1.bb b/recipes/gcc/gcc-cross-sdk_4.4.1.bb
index 77ccf728ab..9f8c75df07 100644
--- a/recipes/gcc/gcc-cross-sdk_4.4.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.4.1.bb
@@ -2,7 +2,7 @@ inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
diff --git a/recipes/gcc/gcc-cross-sdk_4.4.2.bb b/recipes/gcc/gcc-cross-sdk_4.4.2.bb
index 77ccf728ab..9f8c75df07 100644
--- a/recipes/gcc/gcc-cross-sdk_4.4.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.4.2.bb
@@ -2,7 +2,7 @@ inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
diff --git a/recipes/gcc/gcc-cross-sdk_4.4.4.bb b/recipes/gcc/gcc-cross-sdk_4.4.4.bb
index 44abbcf75b..439ae36ffb 100644
--- a/recipes/gcc/gcc-cross-sdk_4.4.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.4.4.bb
@@ -2,7 +2,7 @@ inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
diff --git a/recipes/gcc/gcc-cross-sdk_4.5.bb b/recipes/gcc/gcc-cross-sdk_4.5.bb
index f96607e64e..d1e13d4d77 100644
--- a/recipes/gcc/gcc-cross-sdk_4.5.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.5.bb
@@ -2,7 +2,7 @@ inherit sdk
require gcc-${PV}.inc
require gcc-cross-sdk.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
EXTRA_OECONF += " --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} --with-system-zlib"