aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-20 12:00:17 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 12:00:17 +0200
commit21dbc0814fe2bd1f2cdbfa255d169139842661e9 (patch)
treebcbe5fc375e6f3e1972f148d18914939c72f9896 /recipes/gcc
parentcb70efeb71b3a1e5e8786d3488e4ec3a1580d45a (diff)
downloadopenembedded-21dbc0814fe2bd1f2cdbfa255d169139842661e9.tar.gz
gcc 4.3.2, 4.3.3, 4.4.0: attempt to fix zecke-no-host-includes.patch
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch2
-rw-r--r--recipes/gcc/gcc-4.3.3.inc2
-rw-r--r--recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch2
-rw-r--r--recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch2
-rw-r--r--recipes/gcc/gcc-cross_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.4.0.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch b/recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch
index 6afb10d6ef..1f3b062feb 100644
--- a/recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch
+++ b/recipes/gcc/gcc-4.3.2/zecke-no-host-includes.patch
@@ -6,7 +6,7 @@ Index: gcc-4.0.2/gcc/c-incpath.c
p->construct = 0;
p->user_supplied_p = user_supplied_p;
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
+ /* A common error when cross compiling is including
+ host headers. This code below will try to fail fast
+ for cross compiling. Currently we consider /usr/include,
diff --git a/recipes/gcc/gcc-4.3.3.inc b/recipes/gcc/gcc-4.3.3.inc
index 3e6c0979ce..2947b185b9 100644
--- a/recipes/gcc/gcc-4.3.3.inc
+++ b/recipes/gcc/gcc-4.3.3.inc
@@ -7,7 +7,7 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
-INC_PR = "r3"
+INC_PR = "r4"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
diff --git a/recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch b/recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch
index 6afb10d6ef..1f3b062feb 100644
--- a/recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch
+++ b/recipes/gcc/gcc-4.3.3/zecke-no-host-includes.patch
@@ -6,7 +6,7 @@ Index: gcc-4.0.2/gcc/c-incpath.c
p->construct = 0;
p->user_supplied_p = user_supplied_p;
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
+ /* A common error when cross compiling is including
+ host headers. This code below will try to fail fast
+ for cross compiling. Currently we consider /usr/include,
diff --git a/recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch b/recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch
index 4ccf35f627..abf829c60d 100644
--- a/recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch
+++ b/recipes/gcc/gcc-4.4.0/zecke-no-host-includes.patch
@@ -6,7 +6,7 @@ Index: gcc-4.4+svnr145550/gcc/incpath.c
p->construct = 0;
p->user_supplied_p = user_supplied_p;
-+#ifdef CROSS_COMPILE
++#ifdef CROSS_DIRECTORY_STRUCTURE
+ /* A common error when cross compiling is including
+ host headers. This code below will try to fail fast
+ for cross compiling. Currently we consider /usr/include,
diff --git a/recipes/gcc/gcc-cross_4.3.2.bb b/recipes/gcc/gcc-cross_4.3.2.bb
index 7116611cd5..598da3c912 100644
--- a/recipes/gcc/gcc-cross_4.3.2.bb
+++ b/recipes/gcc/gcc-cross_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
diff --git a/recipes/gcc/gcc-cross_4.4.0.bb b/recipes/gcc/gcc-cross_4.4.0.bb
index e3941b9bd2..731a956ef2 100644
--- a/recipes/gcc/gcc-cross_4.4.0.bb
+++ b/recipes/gcc/gcc-cross_4.4.0.bb
@@ -2,7 +2,7 @@ require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
require gcc-package-cross.inc
-PR = "r0"
+PR = "r1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "