aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:27:59 +0200
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:26:01 +0100
commitaecc68dc21c4acb9c02de667f39b253dd71a4dab (patch)
tree1c9c76ee4c9891bd5282c3a012a9621258508978 /recipes/gcc
parenta0c85998e1b26e5c8a4e04c2aca83363ec47d171 (diff)
downloadopenembedded-aecc68dc21c4acb9c02de667f39b253dd71a4dab.tar.gz
gcc: made sure that no unsubstituted @LDFLAGS@ is left in the generated Makefiles
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-configure-common.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-configure-common.inc b/recipes/gcc/gcc-configure-common.inc
index ee5784afc3..9363585de1 100644
--- a/recipes/gcc/gcc-configure-common.inc
+++ b/recipes/gcc/gcc-configure-common.inc
@@ -89,4 +89,7 @@ do_configure () {
echo "#define STANDARD_INCLUDE_DIR \"${layout_includedir}\"" >> ${S}/gcc/defaults.h
oe_runconf
+
+ # make sure that no @LDFLAG@ is left in the generated Makefile
+ sed -i "s/@LDFLAGS@//g" ${B}/Makefile
}