summaryrefslogtreecommitdiffstats
path: root/recipes/gcc
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-06-19 19:55:22 -0400
committerTom Rini <trini@embeddedalley.com>2009-06-19 19:55:22 -0400
commit793b86cc83d0822d50e65422fd00ce9479129fbe (patch)
tree95785e28437e118e023550bdb2c59c0f37bc56be /recipes/gcc
parent9ee3d21325e571f27b7248370f58eaaaf405e070 (diff)
downloadopenembedded-793b86cc83d0822d50e65422fd00ce9479129fbe.tar.gz
gcc-4.4.0: Switch to INC_PR
Diffstat (limited to 'recipes/gcc')
-rw-r--r--recipes/gcc/gcc-4.4.0.inc2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.4.0.bb2
-rw-r--r--recipes/gcc/gcc-cross_4.4.0.bb2
-rw-r--r--recipes/gcc/gcc_4.4.0.bb2
4 files changed, 5 insertions, 3 deletions
diff --git a/recipes/gcc/gcc-4.4.0.inc b/recipes/gcc/gcc-4.4.0.inc
index 3cb9763545..6ea9123460 100644
--- a/recipes/gcc/gcc-4.4.0.inc
+++ b/recipes/gcc/gcc-4.4.0.inc
@@ -7,6 +7,8 @@ LICENSE = "GPLv3"
DEPENDS = "mpfr gmp"
+INC_PR = "r1"
+
FILESPATHPKG .= ":gcc-$PV"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
diff --git a/recipes/gcc/gcc-cross-sdk_4.4.0.bb b/recipes/gcc/gcc-cross-sdk_4.4.0.bb
index a62d13bd2c..513cca1ddc 100644
--- a/recipes/gcc/gcc-cross-sdk_4.4.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.4.0.bb
@@ -4,7 +4,7 @@ require gcc-${PV}.inc
require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-PR = "r0"
+PR = "${INC_PR}.1"
DEPENDS += "gmp-native mpfr-native"
diff --git a/recipes/gcc/gcc-cross_4.4.0.bb b/recipes/gcc/gcc-cross_4.4.0.bb
index 731a956ef2..4db1b33945 100644
--- a/recipes/gcc/gcc-cross_4.4.0.bb
+++ b/recipes/gcc/gcc-cross_4.4.0.bb
@@ -2,7 +2,7 @@ require gcc-${PV}.inc
require gcc-cross4.inc
require gcc-configure-cross.inc
require gcc-package-cross.inc
-PR = "r1"
+PR = "${INC_PR}.1"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/recipes/gcc/gcc_4.4.0.bb b/recipes/gcc/gcc_4.4.0.bb
index 6ac2b58305..9773205c52 100644
--- a/recipes/gcc/gcc_4.4.0.bb
+++ b/recipes/gcc/gcc_4.4.0.bb
@@ -1,7 +1,7 @@
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc
-PR = "r0"
+PR = "${INC_PR}.1"
# GCC 4.4.0 installs crt* in a '4.4.0' dir....
FILES_${PN} += "\