aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gd')
-rw-r--r--recipes/gd/gd_2.0.21.bb24
-rw-r--r--recipes/gd/gd_2.0.22.bb25
-rw-r--r--recipes/gd/gd_2.0.33.bb30
3 files changed, 79 insertions, 0 deletions
diff --git a/recipes/gd/gd_2.0.21.bb b/recipes/gd/gd_2.0.21.bb
new file mode 100644
index 0000000000..03a506b882
--- /dev/null
+++ b/recipes/gd/gd_2.0.21.bb
@@ -0,0 +1,24 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+DEPENDS = "libpng jpeg zlib"
+
+SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
+S = "${WORKDIR}/gd-${PV}"
+
+inherit autotools gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-xpm"
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}
diff --git a/recipes/gd/gd_2.0.22.bb b/recipes/gd/gd_2.0.22.bb
new file mode 100644
index 0000000000..a54809bf3b
--- /dev/null
+++ b/recipes/gd/gd_2.0.22.bb
@@ -0,0 +1,25 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+DEPENDS = "libpng jpeg zlib"
+PR = "r1"
+
+SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
+S = "${WORKDIR}/gd-${PV}"
+
+inherit autotools binconfig gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-xpm"
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}
diff --git a/recipes/gd/gd_2.0.33.bb b/recipes/gd/gd_2.0.33.bb
new file mode 100644
index 0000000000..7c1f7c3d19
--- /dev/null
+++ b/recipes/gd/gd_2.0.33.bb
@@ -0,0 +1,30 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+DEPENDS = "libpng jpeg zlib"
+PR = "r1"
+
+SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
+S = "${WORKDIR}/gd-${PV}"
+
+inherit autotools binconfig gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-freetype \
+ --without-fontconfig \
+ --without-xpm \
+ --without-x"
+
+EXTRA_OEMAKE = "LDFLAGS=-L${STAGING_LIBDIR}"
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}