aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdal
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gdal
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gdal')
-rw-r--r--recipes/gdal/files/gdal_config.patch61
-rw-r--r--recipes/gdal/gdal_1.3.2.bb42
-rw-r--r--recipes/gdal/gdal_1.5.2.bb40
3 files changed, 143 insertions, 0 deletions
diff --git a/recipes/gdal/files/gdal_config.patch b/recipes/gdal/files/gdal_config.patch
new file mode 100644
index 0000000000..b09cc43faf
--- /dev/null
+++ b/recipes/gdal/files/gdal_config.patch
@@ -0,0 +1,61 @@
+Index: gdal-1.5.2/apps/GNUmakefile
+===================================================================
+--- gdal-1.5.2.orig/apps/GNUmakefile 2007-12-21 04:20:10.000000000 +0100
++++ gdal-1.5.2/apps/GNUmakefile 2008-11-09 20:58:31.506906134 +0100
+@@ -21,7 +21,7 @@
+ ogrtindex$(EXE)
+ endif
+
+-default: gdal-config-inst gdal-config $(BIN_LIST)
++default: gdal-config $(BIN_LIST)
+
+ lib-depend:
+ (cd ../gcore ; $(MAKE) )
+@@ -108,41 +108,26 @@
+ -o test_ogrsf$(EXE)
+
+ clean:
+- $(RM) *.o $(BIN_LIST) core gdal-config gdal-config-inst
++ $(RM) *.o $(BIN_LIST) core gdal-config
+
+ $(DEP_LIBS):
+
+-
+ gdal-config: gdal-config.in ../GDALmake.opt ./GNUmakefile ../VERSION
+ rm -f gdal-config
+ echo '#!/bin/sh' > gdal-config
+- echo 'CONFIG_LIBS="$(CONFIG_LIBS)"' >> gdal-config
++ echo 'CONFIG_LIBS="$(CONFIG_LIBS_INS)"' >> gdal-config
+ echo 'CONFIG_DEP_LIBS="$(LIBS)"' >> gdal-config
+- echo 'CONFIG_PREFIX="$(GDAL_ROOT)"' >> gdal-config
+- echo 'CONFIG_CFLAGS="-I$(GDAL_ROOT)/port -I$(GDAL_ROOT)/gcore -I$(GDAL_ROOT)/alg -I$(GDAL_ROOT)/ogr -I$(GDAL_ROOT)/ogr/ogrsf_frmts"' >> gdal-config
+- echo 'CONFIG_DATA="$(GDAL_ROOT)/data"' >> gdal-config
++ echo 'CONFIG_PREFIX="$(INST_PREFIX)"' >> gdal-config
++ echo 'CONFIG_CFLAGS="-I$(INST_INCLUDE)"' >> gdal-config
++ echo 'CONFIG_DATA="$(INST_DATA)"' >> gdal-config
+ echo 'CONFIG_VERSION="'`cat ../VERSION`'"' >> gdal-config
+ echo 'CONFIG_OGR_ENABLED=$(OGR_ENABLED)' >> gdal-config
+ echo 'CONFIG_FORMATS="$(GDAL_FORMATS)"' >> gdal-config
+ cat gdal-config.in >> gdal-config
+ chmod a+x gdal-config
+
+-gdal-config-inst: gdal-config.in ../GDALmake.opt ./GNUmakefile ../VERSION
+- rm -f gdal-config-inst
+- echo '#!/bin/sh' > gdal-config-inst
+- echo 'CONFIG_LIBS="$(CONFIG_LIBS_INS)"' >> gdal-config-inst
+- echo 'CONFIG_DEP_LIBS="$(LIBS)"' >> gdal-config-inst
+- echo 'CONFIG_PREFIX="$(INST_PREFIX)"' >> gdal-config-inst
+- echo 'CONFIG_CFLAGS="-I$(INST_INCLUDE)"' >> gdal-config-inst
+- echo 'CONFIG_DATA="$(INST_DATA)"' >> gdal-config-inst
+- echo 'CONFIG_VERSION="'`cat ../VERSION`'"' >> gdal-config-inst
+- echo 'CONFIG_OGR_ENABLED=$(OGR_ENABLED)' >> gdal-config-inst
+- echo 'CONFIG_FORMATS="$(GDAL_FORMATS)"' >> gdal-config-inst
+- cat gdal-config.in >> gdal-config-inst
+- chmod a+x gdal-config-inst
+-
+
+ install: default
+ for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
+- $(INSTALL) gdal-config-inst $(DESTDIR)$(INST_BIN)/gdal-config
++ $(INSTALL) gdal-config $(DESTDIR)$(INST_BIN)/
+
diff --git a/recipes/gdal/gdal_1.3.2.bb b/recipes/gdal/gdal_1.3.2.bb
new file mode 100644
index 0000000000..60f86b165a
--- /dev/null
+++ b/recipes/gdal/gdal_1.3.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=internal \
+ --with-png=internal \
+ --with-jpeg=internal \
+ --with-libtiff=internal \
+ "
+
+do_configure_append() {
+ sed -i s:/usr/lib:${D}${libdir}: GDALmake.opt
+ sed -i s:/usr/bin:${D}${bindir}: GDALmake.opt
+ sed -i s:/usr/share:${D}${datadir}: GDALmake.opt
+ sed -i s:/usr/include:${D}${includedir}: GDALmake.opt
+}
+
+do_compile() {
+ oe_runmake default
+}
+
+
+do_package_prepend() {
+ # the brokenness....
+ os.system('cp -pPR ${D}${D}* ${D}../')
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/gdal/gdal_1.5.2.bb b/recipes/gdal/gdal_1.5.2.bb
new file mode 100644
index 0000000000..a92e40fadc
--- /dev/null
+++ b/recipes/gdal/gdal_1.5.2.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "proj-4 sqlite3 zlib jpeg libpng tiff giflib curl jasper expat"
+PR = "r2"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz \
+ file://gdal_config.patch;patch=1 \
+ "
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=${STAGING_DIR_TARGET} \
+ --with-png=${STAGING_DIR_TARGET} \
+ --with-jpeg=${STAGING_DIR_TARGET} \
+ --with-libtiff=${STAGING_DIR_TARGET} \
+ --with-gif=${STAGING_DIR_TARGET} \
+ --with-jasper=${STAGING_DIR_TARGET} \
+ --with-expat=${STAGING_DIR_TARGET} \
+ --with-expat-inc=${STAGING_INCDIR} \
+ --with-expat-lib=${STAGING_LIBDIR} \
+"
+
+# GDAL clutter /usr/share with files instead of using a subdir :(
+FILES_${PN}-dev += "${datadir}"
+
+do_compile() {
+ oe_runmake default
+}
+
+do_stage() {
+ autotools_stage_all
+}
+