aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorTim Harvey <harvey.tim@gmail.com>2010-10-13 15:58:20 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-13 15:58:20 -0700
commit90cdd0e3813a274a19a2625f664542ef7f93e8f7 (patch)
treed1089bc00f6ff9c66862992188daa25b1df28073 /recipes/gdb
parent278fe3bc04b4a0d31ba080d7b43c72a6a09fb70a (diff)
downloadopenembedded-90cdd0e3813a274a19a2625f664542ef7f93e8f7.tar.gz
gdb-cross-sdk.inc: Do not run autoreconf
* GDB autoconfigury mandates uses of a given autconf e.g. 2.64 for gdb 7.1, but OE's default autoconf native is 2.65 and it does not go so well with gdb. We do not really need to recreate configure if it its not needed Signed-off-by: Tim Harvey <harvey.tim@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 9949e103d1..adc2ed37c9 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -7,7 +7,7 @@ inherit sdk
DEPENDS = "ncurses-native zlib-native expat-native flex-native"
EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
-do_configure_append () {
+do_configure () {
cd ${B}
oe_runmake configure-host
sed -e 's,-lncurses,${STAGING_LIBDIR_NATIVE}/libncurses.a ${STAGING_LIBDIR_NATIVE}/libtinfo.a ,g' -i ${B}/gdb/Makefile
@@ -17,4 +17,5 @@ do_configure_append () {
for SIM in ${B}/sim/*/Makefile; do
[ -f $SIM ] && sed -e 's,-lz, ${STAGING_LIBDIR_NATIVE}/libz.a ,g' -i $SIM
done
+ oe_runconf
}