aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-10-13 17:44:07 -0700
committerTom Rini <tom_rini@mentor.com>2010-10-13 17:44:07 -0700
commitd823e741892288283a5aaffe91693fefd8b973ed (patch)
treef6611ab51867e01210a7765d889971417e37d0cc /recipes/gdb
parentd021e2b933c13f9b2028207a6db0858c1fbb4359 (diff)
downloadopenembedded-d823e741892288283a5aaffe91693fefd8b973ed.tar.gz
gdb-cross-sdk.inc: We must use do_configure_append
The goal is to have oe_runconf happen twice. So we want the normal gdb-cross.inc do_configure to happen so we get an initial configure. Then gdb-cross-sdk does its thing and then we run oe_runconf again. All of this shows that we really need to sit down and think and test the dance we're doing here. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 1a9360dda4..43d13a5601 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -7,7 +7,7 @@ EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' L
# Since we statically link against the required host libraries we don't
# add a depenency on the -sdk versions of them.
-do_configure () {
+do_configure_append () {
cd ${B}
oe_runmake configure-host
sed -e 's,-lncurses,${STAGING_LIBDIR_NATIVE}/libncurses.a ${STAGING_LIBDIR_NATIVE}/libtinfo.a ,g' -i ${B}/gdb/Makefile