aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-10 11:21:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:07:27 +0200
commit44985d56bc556786812a0a02d6219afd31a7381d (patch)
tree9dfeab9bd98dc6408835b7359861c8dc8ea6fffb /recipes/gdb
parenta8e889754b1bdb261b85ac7de1c1f929ad597c09 (diff)
downloadopenembedded-44985d56bc556786812a0a02d6219afd31a7381d.tar.gz
recipes: move checksums to recipes from checksums.ini
* fetch all *.bb with patched utils.bbclass appending all checksums found only in checksums.ini to recipe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-canadian-sdk_6.8.bb3
-rw-r--r--recipes/gdb/gdb-canadian-sdk_7.0.bb3
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.6.bb3
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.8.bb3
-rw-r--r--recipes/gdb/gdb-cross-sdk_7.0.bb3
-rw-r--r--recipes/gdb/gdb-cross_6.3.bb3
-rw-r--r--recipes/gdb/gdb-cross_6.4.bb4
-rw-r--r--recipes/gdb/gdb-cross_6.6.bb3
-rw-r--r--recipes/gdb/gdb-cross_6.7.1.bb3
-rw-r--r--recipes/gdb/gdb-cross_6.8.bb3
-rw-r--r--recipes/gdb/gdb-cross_7.0.bb3
-rw-r--r--recipes/gdb/gdb_6.3.bb3
-rw-r--r--recipes/gdb/gdb_6.4.bb3
-rw-r--r--recipes/gdb/gdb_6.6.bb3
-rw-r--r--recipes/gdb/gdb_6.7.1.bb3
-rw-r--r--recipes/gdb/gdb_6.8.bb3
-rw-r--r--recipes/gdb/gdb_7.0.bb3
-rw-r--r--recipes/gdb/gdbserver_6.6.bb3
-rw-r--r--recipes/gdb/gdbserver_6.7.1.bb3
-rw-r--r--recipes/gdb/gdbserver_6.8.bb3
-rw-r--r--recipes/gdb/gdbserver_7.0.bb3
21 files changed, 63 insertions, 1 deletions
diff --git a/recipes/gdb/gdb-canadian-sdk_6.8.bb b/recipes/gdb/gdb-canadian-sdk_6.8.bb
index db45cfdf16..be05d50f0d 100644
--- a/recipes/gdb/gdb-canadian-sdk_6.8.bb
+++ b/recipes/gdb/gdb-canadian-sdk_6.8.bb
@@ -12,3 +12,6 @@ PR = "r1"
do_stage() {
:
}
+
+SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
+SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-canadian-sdk_7.0.bb b/recipes/gdb/gdb-canadian-sdk_7.0.bb
index 3b6eb2b07f..d09530720a 100644
--- a/recipes/gdb/gdb-canadian-sdk_7.0.bb
+++ b/recipes/gdb/gdb-canadian-sdk_7.0.bb
@@ -9,3 +9,6 @@ SRC_URI += "\
do_stage() {
:
}
+
+SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
+SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"
diff --git a/recipes/gdb/gdb-cross-sdk_6.6.bb b/recipes/gdb/gdb-cross-sdk_6.6.bb
index 7136d4e650..62b9f825c7 100644
--- a/recipes/gdb/gdb-cross-sdk_6.6.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.6.bb
@@ -12,3 +12,6 @@ SRC_URI += "file://early_debug_in_nptl.patch;patch=1;pnum=0"
do_stage() {
:
}
+
+SRC_URI[md5sum] = "18be4e7a1ac713bda93d00fee20bbef8"
+SRC_URI[sha256sum] = "c119ce82f0e42d3412420c42c1ead75e0b9de67131a5c9dd3cdab509f65ddfdd"
diff --git a/recipes/gdb/gdb-cross-sdk_6.8.bb b/recipes/gdb/gdb-cross-sdk_6.8.bb
index 77ce5c8b7e..ff27808f23 100644
--- a/recipes/gdb/gdb-cross-sdk_6.8.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.8.bb
@@ -13,3 +13,6 @@ PR = "r2"
do_stage() {
:
}
+
+SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
+SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-cross-sdk_7.0.bb b/recipes/gdb/gdb-cross-sdk_7.0.bb
index 76f3f7540d..16f3a56986 100644
--- a/recipes/gdb/gdb-cross-sdk_7.0.bb
+++ b/recipes/gdb/gdb-cross-sdk_7.0.bb
@@ -11,3 +11,6 @@ inherit sdk
do_stage() {
:
}
+
+SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
+SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"
diff --git a/recipes/gdb/gdb-cross_6.3.bb b/recipes/gdb/gdb-cross_6.3.bb
index fd2f97245c..52f0575db1 100644
--- a/recipes/gdb/gdb-cross_6.3.bb
+++ b/recipes/gdb/gdb-cross_6.3.bb
@@ -7,3 +7,6 @@ PR = "r3"
SRC_URI += "file://sim-install-makefile.patch;patch=1 \
file://sim-install-makefile-common.patch;patch=1"
+
+SRC_URI[md5sum] = "812de9e756d53c749ea5516d9ffa5905"
+SRC_URI[sha256sum] = "c06bf9715436b3a28c189163aa5ca42b46af8286659827f033eaaf7d8b1fc342"
diff --git a/recipes/gdb/gdb-cross_6.4.bb b/recipes/gdb/gdb-cross_6.4.bb
index 2e6de0895e..7994a995f1 100644
--- a/recipes/gdb/gdb-cross_6.4.bb
+++ b/recipes/gdb/gdb-cross_6.4.bb
@@ -3,4 +3,6 @@ LICENSE = "GPLv2"
inherit cross
-PR = "r1" \ No newline at end of file
+PR = "r1"
+SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
+SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb-cross_6.6.bb b/recipes/gdb/gdb-cross_6.6.bb
index a1851f7777..9040e54f17 100644
--- a/recipes/gdb/gdb-cross_6.6.bb
+++ b/recipes/gdb/gdb-cross_6.6.bb
@@ -7,3 +7,6 @@ PR = "r3"
SRC_URI += "file://early_debug_in_nptl.patch;patch=1;pnum=0"
+
+SRC_URI[md5sum] = "18be4e7a1ac713bda93d00fee20bbef8"
+SRC_URI[sha256sum] = "c119ce82f0e42d3412420c42c1ead75e0b9de67131a5c9dd3cdab509f65ddfdd"
diff --git a/recipes/gdb/gdb-cross_6.7.1.bb b/recipes/gdb/gdb-cross_6.7.1.bb
index 0681029694..59cc945c61 100644
--- a/recipes/gdb/gdb-cross_6.7.1.bb
+++ b/recipes/gdb/gdb-cross_6.7.1.bb
@@ -19,3 +19,6 @@ do_configure_prepend() {
done
}
+
+SRC_URI[md5sum] = "7a74dcafdd39d18678e5b5cc2c50bb0c"
+SRC_URI[sha256sum] = "66e6ff871a7ed71ea433b8341ffebbe48590119e43a42953d392f5ce517c95e4"
diff --git a/recipes/gdb/gdb-cross_6.8.bb b/recipes/gdb/gdb-cross_6.8.bb
index 2c24d4cac8..d0ba1302c7 100644
--- a/recipes/gdb/gdb-cross_6.8.bb
+++ b/recipes/gdb/gdb-cross_6.8.bb
@@ -7,3 +7,6 @@ SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
inherit cross
PR = "r3"
+
+SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
+SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb-cross_7.0.bb b/recipes/gdb/gdb-cross_7.0.bb
index 6883b7c2e8..1075356ced 100644
--- a/recipes/gdb/gdb-cross_7.0.bb
+++ b/recipes/gdb/gdb-cross_7.0.bb
@@ -5,3 +5,6 @@ SRC_URI += " \
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
inherit cross
+
+SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
+SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"
diff --git a/recipes/gdb/gdb_6.3.bb b/recipes/gdb/gdb_6.3.bb
index 69d9e7117d..01fb150c5e 100644
--- a/recipes/gdb/gdb_6.3.bb
+++ b/recipes/gdb/gdb_6.3.bb
@@ -2,3 +2,6 @@ require gdb.inc
LICENSE = "GPLv2"
PR = "r4"
+
+SRC_URI[md5sum] = "812de9e756d53c749ea5516d9ffa5905"
+SRC_URI[sha256sum] = "c06bf9715436b3a28c189163aa5ca42b46af8286659827f033eaaf7d8b1fc342"
diff --git a/recipes/gdb/gdb_6.4.bb b/recipes/gdb/gdb_6.4.bb
index b3c53a27ae..022b8cf955 100644
--- a/recipes/gdb/gdb_6.4.bb
+++ b/recipes/gdb/gdb_6.4.bb
@@ -2,3 +2,6 @@ require gdb.inc
LICENSE = "GPLv2"
PR = "r2"
+
+SRC_URI[md5sum] = "7dc98022ee96bba5331f195dc8a5491a"
+SRC_URI[sha256sum] = "719f2bbd79d55cdd6f5e31b49cec49df71ddb32a4439dba678de0e09330096da"
diff --git a/recipes/gdb/gdb_6.6.bb b/recipes/gdb/gdb_6.6.bb
index 501e1164ff..5ed504a357 100644
--- a/recipes/gdb/gdb_6.6.bb
+++ b/recipes/gdb/gdb_6.6.bb
@@ -4,3 +4,6 @@ LICENSE = "GPLv2"
PR = "r5"
SRC_URI += "file://early_debug_in_nptl.patch;patch=1;pnum=0"
+
+SRC_URI[md5sum] = "18be4e7a1ac713bda93d00fee20bbef8"
+SRC_URI[sha256sum] = "c119ce82f0e42d3412420c42c1ead75e0b9de67131a5c9dd3cdab509f65ddfdd"
diff --git a/recipes/gdb/gdb_6.7.1.bb b/recipes/gdb/gdb_6.7.1.bb
index fb9ed3f1bf..ec99c3fbcd 100644
--- a/recipes/gdb/gdb_6.7.1.bb
+++ b/recipes/gdb/gdb_6.7.1.bb
@@ -6,3 +6,6 @@ PR = "r1"
DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
S_avr32 = "${WORKDIR}/gdb-6.7.1.atmel.1.0.3"
+
+SRC_URI[md5sum] = "7a74dcafdd39d18678e5b5cc2c50bb0c"
+SRC_URI[sha256sum] = "66e6ff871a7ed71ea433b8341ffebbe48590119e43a42953d392f5ce517c95e4"
diff --git a/recipes/gdb/gdb_6.8.bb b/recipes/gdb/gdb_6.8.bb
index ff14c0f31f..00d1a67a0b 100644
--- a/recipes/gdb/gdb_6.8.bb
+++ b/recipes/gdb/gdb_6.8.bb
@@ -5,3 +5,6 @@ SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
PR = "r3"
+
+SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
+SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdb_7.0.bb b/recipes/gdb/gdb_7.0.bb
index c3aa49d0e4..ba40e25b64 100644
--- a/recipes/gdb/gdb_7.0.bb
+++ b/recipes/gdb/gdb_7.0.bb
@@ -6,3 +6,6 @@ SRC_URI += "\
# Work-around problems while creating libbfd.a
EXTRA_OECONF += "--enable-static"
+
+SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
+SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"
diff --git a/recipes/gdb/gdbserver_6.6.bb b/recipes/gdb/gdbserver_6.6.bb
index bad9ae7158..40df157566 100644
--- a/recipes/gdb/gdbserver_6.6.bb
+++ b/recipes/gdb/gdbserver_6.6.bb
@@ -3,3 +3,6 @@ require gdbserver.inc
LICENSE = "GPLv2"
PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "18be4e7a1ac713bda93d00fee20bbef8"
+SRC_URI[sha256sum] = "c119ce82f0e42d3412420c42c1ead75e0b9de67131a5c9dd3cdab509f65ddfdd"
diff --git a/recipes/gdb/gdbserver_6.7.1.bb b/recipes/gdb/gdbserver_6.7.1.bb
index cb83d6f2c7..da6365e5da 100644
--- a/recipes/gdb/gdbserver_6.7.1.bb
+++ b/recipes/gdb/gdbserver_6.7.1.bb
@@ -8,3 +8,6 @@ DEFAULT_PREFERENCE_avr32 = "99"
SRC_URI_avr32 = " http://avr32linux.org/twiki/pub/Main/GDBPatches/gdb-6.7.1.atmel.1.0.3.tar.bz2"
S_avr32 = "${WORKDIR}/gdb-6.7.1.atmel.1.0.3"
+
+SRC_URI[md5sum] = "7a74dcafdd39d18678e5b5cc2c50bb0c"
+SRC_URI[sha256sum] = "66e6ff871a7ed71ea433b8341ffebbe48590119e43a42953d392f5ce517c95e4"
diff --git a/recipes/gdb/gdbserver_6.8.bb b/recipes/gdb/gdbserver_6.8.bb
index a6639b420d..9e17a6fe37 100644
--- a/recipes/gdb/gdbserver_6.8.bb
+++ b/recipes/gdb/gdbserver_6.8.bb
@@ -3,3 +3,6 @@ require gdbserver.inc
LICENSE = "GPLv3"
PR = "${INC_PR}.1"
+
+SRC_URI[md5sum] = "925695333524108291dc4012c4c9cbb8"
+SRC_URI[sha256sum] = "a3c5455f30ffb3e6eeafb9e54598b48f9fbf46e3e99f431120360c183ddcc889"
diff --git a/recipes/gdb/gdbserver_7.0.bb b/recipes/gdb/gdbserver_7.0.bb
index 96de5e90e5..8c82b15347 100644
--- a/recipes/gdb/gdbserver_7.0.bb
+++ b/recipes/gdb/gdbserver_7.0.bb
@@ -3,3 +3,6 @@ require gdbserver.inc
LICENSE = "GPLv3"
PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "67b4144db385620d7b93f7b0c26800f7"
+SRC_URI[sha256sum] = "ccff6cab0e847c486d30b70bdddac4e6646bafcecaa3b63134d6e3d4d5a4b91d"