aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-03-22 09:00:01 -0700
committerTom Rini <tom_rini@mentor.com>2010-03-22 09:02:40 -0700
commit73d7d78abb695ac79e22bdae060de0d0e2e64bc5 (patch)
tree2c3b002297b078fc6d10aeb23a8bb0873a512c2a /recipes/gdb
parentce7314b9776757c1fffc9c60098f2c1ffd3e0b37 (diff)
downloadopenembedded-73d7d78abb695ac79e22bdae060de0d0e2e64bc5.tar.gz
gdb*: Add flex-native (and make sure we have relevant zlib) in DEPENDS.
Diffstat (limited to 'recipes/gdb')
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.6.bb2
-rw-r--r--recipes/gdb/gdb-cross-sdk_6.8.bb2
-rw-r--r--recipes/gdb/gdb-cross-sdk_7.0.bb2
-rw-r--r--recipes/gdb/gdb-cross.inc2
-rw-r--r--recipes/gdb/gdb.inc2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes/gdb/gdb-cross-sdk_6.6.bb b/recipes/gdb/gdb-cross-sdk_6.6.bb
index aa6e7563cf..7136d4e650 100644
--- a/recipes/gdb/gdb-cross-sdk_6.6.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.6.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
inherit sdk
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
PR = "r3"
diff --git a/recipes/gdb/gdb-cross-sdk_6.8.bb b/recipes/gdb/gdb-cross-sdk_6.8.bb
index ff4423ec44..77ce5c8b7e 100644
--- a/recipes/gdb/gdb-cross-sdk_6.8.bb
+++ b/recipes/gdb/gdb-cross-sdk_6.8.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "file://gcc-4.3-build-error.patch;patch=1;pnum=0 \
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
inherit sdk
diff --git a/recipes/gdb/gdb-cross-sdk_7.0.bb b/recipes/gdb/gdb-cross-sdk_7.0.bb
index 47b8faddb1..76f3f7540d 100644
--- a/recipes/gdb/gdb-cross-sdk_7.0.bb
+++ b/recipes/gdb/gdb-cross-sdk_7.0.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
SRC_URI += "\
file://gdb-6.8-fix-compile-karmic.patch;patch=1"
-DEPENDS = "ncurses-sdk zlib-sdk"
+DEPENDS = "ncurses-sdk zlib-sdk flex-native"
inherit sdk
diff --git a/recipes/gdb/gdb-cross.inc b/recipes/gdb/gdb-cross.inc
index 6d4c3d177e..ca89d4fdb0 100644
--- a/recipes/gdb/gdb-cross.inc
+++ b/recipes/gdb/gdb-cross.inc
@@ -1,6 +1,6 @@
require gdb-common.inc
-DEPENDS = "ncurses-native"
+DEPENDS = "ncurses-native zlib-native flex-native"
EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
diff --git a/recipes/gdb/gdb.inc b/recipes/gdb/gdb.inc
index a63fb6159b..a519cef584 100644
--- a/recipes/gdb/gdb.inc
+++ b/recipes/gdb/gdb.inc
@@ -2,7 +2,7 @@ require gdb-common.inc
DEFAULT_PREFERENCE_avr32 = "-99"
-DEPENDS = "ncurses readline"
+DEPENDS = "ncurses readline zlib flex-native"
PACKAGES =+ "gdbserver"
FILES_gdbserver = "${bindir}/gdbserver"