aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gdbus-binding-tool
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-12-24 11:10:21 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-12-24 11:46:29 +0100
commit9f510a08223fddf04ab66ae6282a63927e2f2423 (patch)
tree187c766305f1940c9cd7d74f2c7c06518ac1e442 /recipes/gdbus-binding-tool
parent75527d4842223cc831b2eaaed0150f28ff467014 (diff)
downloadopenembedded-9f510a08223fddf04ab66ae6282a63927e2f2423.tar.gz
gdbus-binding-tool: new recipe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gdbus-binding-tool')
-rw-r--r--recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb b/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb
new file mode 100644
index 0000000000..c7b3c1c845
--- /dev/null
+++ b/recipes/gdbus-binding-tool/gdbus-binding-tool_git.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "gdbus-binding-tool is used to generate C code for interacting with remote objects using D-Bus."
+DEPENDS = "glib-2.0 gdbus-binding-tool-native"
+DEPENDS_virtclass-native = "glib-2.0-native"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://anongit.freedesktop.org/~david/${BPN};protocol=git;branch=master"
+SRCREV = "229fd9adbb6bd9d824b38a3bd092229016540f41"
+PV = "0.1+gitr${SRCPV}"
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ # missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough
+ sed -i '/^doc\/Makefile/d' ${S}/configure.ac
+ sed -i 's/SUBDIRS = src doc/SUBDIRS = src/g' ${S}/Makefile.am
+
+ # cannot execute target binary, so use staged native
+ sed -i "s#\$(top_builddir)/src/gdbus-codegen#${STAGING_BINDIR_NATIVE}/gdbus-codegen#g" ${S}/src/Makefile.am
+}
+do_configure_prepend_virtclass-native() {
+ # missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough
+ sed -i '/^doc\/Makefile/d' ${S}/configure.ac
+ sed -i 's/SUBDIRS = src doc/SUBDIRS = src/g' ${S}/Makefile.am
+}
+
+BBCLASSEXTEND = "native"