aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geda/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/geda/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/geda/files')
-rw-r--r--recipes/geda/files/bad-include.patch13
-rw-r--r--recipes/geda/files/skip-python-checks.patch42
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/geda/files/bad-include.patch b/recipes/geda/files/bad-include.patch
new file mode 100644
index 0000000000..b64f351950
--- /dev/null
+++ b/recipes/geda/files/bad-include.patch
@@ -0,0 +1,13 @@
+Index: geda-gschem-1.4.1/src/Makefile.am
+===================================================================
+--- geda-gschem-1.4.1.orig/src/Makefile.am 2008-09-28 20:59:54.000000000 +0000
++++ geda-gschem-1.4.1/src/Makefile.am 2008-12-02 17:06:43.000000000 +0000
+@@ -30,7 +30,7 @@
+ AM_CFLAGS = -Wall
+ endif
+
+-INCLUDES = -I$(prefix)/include -I$(top_srcdir)/intl -I$(top_srcdir)/include @GSCHEM_CFLAGS@
++INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir)/include @GSCHEM_CFLAGS@
+ gschem_LDADD = -L$(prefix)/lib @GSCHEM_LDFLAGS@ @LIBINTL@
+
+ localedir = @datadir@/locale
diff --git a/recipes/geda/files/skip-python-checks.patch b/recipes/geda/files/skip-python-checks.patch
new file mode 100644
index 0000000000..8043ff340c
--- /dev/null
+++ b/recipes/geda/files/skip-python-checks.patch
@@ -0,0 +1,42 @@
+Index: geda-xgsch2pcb-0.1.2/configure.ac
+===================================================================
+--- geda-xgsch2pcb-0.1.2.orig/configure.ac 2008-01-11 05:16:07.000000000 +0000
++++ geda-xgsch2pcb-0.1.2/configure.ac 2008-12-09 15:03:31.000000000 +0000
+@@ -39,15 +39,7 @@
+
+ AC_DEFUN([AC_PYTHON_MODULE],[
+ AC_MSG_CHECKING([for python module $1])
+- $PYTHON -c "import $1" > /dev/null 2>&1
+- if test $? -eq 0; then
+- AC_MSG_RESULT(yes)
+- else
+- AC_MSG_RESULT(no)
+- if test -n "$2"; then
+- AC_MSG_ERROR([python module $1 is required])
+- fi
+- fi
++ AC_MSG_RESULT(skipping)
+ ])
+
+
+@@ -135,20 +127,6 @@
+ AC_MSG_CHECKING(for gtk+ >= $GTK_WANTVERSION)
+ cat > conftest.py <<[EOF
+ import sys
+-try:
+- import gtk
+- ver = gtk.gtk_version
+- sys.stdout.write(".".join(map(str, ver)))
+- if len(sys.argv) > 1:
+- wantver = sys.argv[1].split(".")
+- wantver = map(int, wantver)
+- for i in range(len(wantver)):
+- if i > len(ver):
+- break
+- if wantver[i] > ver[i]:
+- sys.exit(1)
+-except:
+- sys.exit(1)
+ sys.exit(0)
+ EOF]
+