aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/geda
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/geda
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/geda')
-rw-r--r--recipes/geda/files/bad-include.patch13
-rw-r--r--recipes/geda/files/skip-python-checks.patch42
-rw-r--r--recipes/geda/geda-docs_1.4.1.bb8
-rw-r--r--recipes/geda/geda-examples_1.4.1.bb8
-rw-r--r--recipes/geda/geda-gattrib_1.4.1.bb11
-rw-r--r--recipes/geda/geda-gnetlist_1.4.1.bb9
-rw-r--r--recipes/geda/geda-gschem_1.4.1.bb12
-rw-r--r--recipes/geda/geda-gsymcheck_1.4.1.bb9
-rw-r--r--recipes/geda/geda-symbols_1.4.1.bb9
-rw-r--r--recipes/geda/geda-utils_1.4.1.bb10
-rw-r--r--recipes/geda/geda-xgsch2pcb_0.1.2.bb19
-rw-r--r--recipes/geda/geda_1.4.1.bb6
-rw-r--r--recipes/geda/libgeda_1.4.1.bb20
-rw-r--r--recipes/geda/pcb_20081128.bb14
14 files changed, 190 insertions, 0 deletions
diff --git a/recipes/geda/files/bad-include.patch b/recipes/geda/files/bad-include.patch
new file mode 100644
index 0000000000..b64f351950
--- /dev/null
+++ b/recipes/geda/files/bad-include.patch
@@ -0,0 +1,13 @@
+Index: geda-gschem-1.4.1/src/Makefile.am
+===================================================================
+--- geda-gschem-1.4.1.orig/src/Makefile.am 2008-09-28 20:59:54.000000000 +0000
++++ geda-gschem-1.4.1/src/Makefile.am 2008-12-02 17:06:43.000000000 +0000
+@@ -30,7 +30,7 @@
+ AM_CFLAGS = -Wall
+ endif
+
+-INCLUDES = -I$(prefix)/include -I$(top_srcdir)/intl -I$(top_srcdir)/include @GSCHEM_CFLAGS@
++INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir)/include @GSCHEM_CFLAGS@
+ gschem_LDADD = -L$(prefix)/lib @GSCHEM_LDFLAGS@ @LIBINTL@
+
+ localedir = @datadir@/locale
diff --git a/recipes/geda/files/skip-python-checks.patch b/recipes/geda/files/skip-python-checks.patch
new file mode 100644
index 0000000000..8043ff340c
--- /dev/null
+++ b/recipes/geda/files/skip-python-checks.patch
@@ -0,0 +1,42 @@
+Index: geda-xgsch2pcb-0.1.2/configure.ac
+===================================================================
+--- geda-xgsch2pcb-0.1.2.orig/configure.ac 2008-01-11 05:16:07.000000000 +0000
++++ geda-xgsch2pcb-0.1.2/configure.ac 2008-12-09 15:03:31.000000000 +0000
+@@ -39,15 +39,7 @@
+
+ AC_DEFUN([AC_PYTHON_MODULE],[
+ AC_MSG_CHECKING([for python module $1])
+- $PYTHON -c "import $1" > /dev/null 2>&1
+- if test $? -eq 0; then
+- AC_MSG_RESULT(yes)
+- else
+- AC_MSG_RESULT(no)
+- if test -n "$2"; then
+- AC_MSG_ERROR([python module $1 is required])
+- fi
+- fi
++ AC_MSG_RESULT(skipping)
+ ])
+
+
+@@ -135,20 +127,6 @@
+ AC_MSG_CHECKING(for gtk+ >= $GTK_WANTVERSION)
+ cat > conftest.py <<[EOF
+ import sys
+-try:
+- import gtk
+- ver = gtk.gtk_version
+- sys.stdout.write(".".join(map(str, ver)))
+- if len(sys.argv) > 1:
+- wantver = sys.argv[1].split(".")
+- wantver = map(int, wantver)
+- for i in range(len(wantver)):
+- if i > len(ver):
+- break
+- if wantver[i] > ver[i]:
+- sys.exit(1)
+-except:
+- sys.exit(1)
+ sys.exit(0)
+ EOF]
+
diff --git a/recipes/geda/geda-docs_1.4.1.bb b/recipes/geda/geda-docs_1.4.1.bb
new file mode 100644
index 0000000000..a35d41514b
--- /dev/null
+++ b/recipes/geda/geda-docs_1.4.1.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-examples_1.4.1.bb b/recipes/geda/geda-examples_1.4.1.bb
new file mode 100644
index 0000000000..a35d41514b
--- /dev/null
+++ b/recipes/geda/geda-examples_1.4.1.bb
@@ -0,0 +1,8 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-gattrib_1.4.1.bb b/recipes/geda/geda-gattrib_1.4.1.bb
new file mode 100644
index 0000000000..af4ea94153
--- /dev/null
+++ b/recipes/geda/geda-gattrib_1.4.1.bb
@@ -0,0 +1,11 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA ${datadir}/icons"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-update-desktop-database"
diff --git a/recipes/geda/geda-gnetlist_1.4.1.bb b/recipes/geda/geda-gnetlist_1.4.1.bb
new file mode 100644
index 0000000000..4f560d3d37
--- /dev/null
+++ b/recipes/geda/geda-gnetlist_1.4.1.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-gschem_1.4.1.bb b/recipes/geda/geda-gschem_1.4.1.bb
new file mode 100644
index 0000000000..7613f3c6a5
--- /dev/null
+++ b/recipes/geda/geda-gschem_1.4.1.bb
@@ -0,0 +1,12 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA ${datadir}/icons"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz \
+ file://bad-include.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-update-desktop-database"
diff --git a/recipes/geda/geda-gsymcheck_1.4.1.bb b/recipes/geda/geda-gsymcheck_1.4.1.bb
new file mode 100644
index 0000000000..463da2de99
--- /dev/null
+++ b/recipes/geda/geda-gsymcheck_1.4.1.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA ${datadir}/icons"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-symbols_1.4.1.bb b/recipes/geda/geda-symbols_1.4.1.bb
new file mode 100644
index 0000000000..4f560d3d37
--- /dev/null
+++ b/recipes/geda/geda-symbols_1.4.1.bb
@@ -0,0 +1,9 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA"
+
+DEPENDS = "gtk+ libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-utils_1.4.1.bb b/recipes/geda/geda-utils_1.4.1.bb
new file mode 100644
index 0000000000..ea61665d9d
--- /dev/null
+++ b/recipes/geda/geda-utils_1.4.1.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "gEDA/gaf's Utilities"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA"
+
+DEPENDS = "libgeda"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig
diff --git a/recipes/geda/geda-xgsch2pcb_0.1.2.bb b/recipes/geda/geda-xgsch2pcb_0.1.2.bb
new file mode 100644
index 0000000000..ccfe151955
--- /dev/null
+++ b/recipes/geda/geda-xgsch2pcb_0.1.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Graphical front-end for the gschem -> pcb workflow"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/icons"
+
+DEPENDS = "python-native"
+# python-codecs for gettext.py
+RDEPENDS = "geda-gschem geda-utils pcb python-codecs python-dbus python-pygtk python-subprocess"
+
+SRC_URI = "http://geda.seul.org/dist/${P}.tar.gz \
+ file://skip-python-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-update-desktop-database"
+
+do_configure_prepend() {
+ sed -i -e s:\\\$\(PYTHON\):${bindir}/python:g Makefile.am
+}
diff --git a/recipes/geda/geda_1.4.1.bb b/recipes/geda/geda_1.4.1.bb
new file mode 100644
index 0000000000..ee9394d9f2
--- /dev/null
+++ b/recipes/geda/geda_1.4.1.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "Virtual package including the whole gEDA suite"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+
+DEPENDS = "libgeda gtk+"
+RRECOMMENDS = "geda-utils geda-gattrib geda-gnetlist geda-gschem geda-gsymcheck geda-symbols geda-docs geda-examples"
diff --git a/recipes/geda/libgeda_1.4.1.bb b/recipes/geda/libgeda_1.4.1.bb
new file mode 100644
index 0000000000..a00a1d5cde
--- /dev/null
+++ b/recipes/geda/libgeda_1.4.1.bb
@@ -0,0 +1,20 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += "${datadir}/gEDA ${datadir}/icons ${datadir}/mime/packages"
+# NOTE: Old KDE integration ${datadir}/mimelnk/application/*.desktop are ignored intentionally
+
+DEPENDS = "zlib gtk+ guile libpng"
+
+SRC_URI = "http://geda.seul.org/release/v1.4/${PV}/${P}.tar.gz"
+
+inherit autotools pkgconfig mime
+
+EXTRA_OECONF = "--disable-update-mime-database --disable-static"
+
+do_install_prepend() {
+ sed -i 's:${STAGING_DIR_HOST}::g' libgeda.pc
+}
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/geda/pcb_20081128.bb b/recipes/geda/pcb_20081128.bb
new file mode 100644
index 0000000000..367569f7da
--- /dev/null
+++ b/recipes/geda/pcb_20081128.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "PCB Designer"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://geda.seul.org"
+FILES_${PN} += " ${datadir}/icons ${datadir}/mime/packages"
+# NOTE: Old KDE integration ${datadir}/mimelnk/application/*.desktop are ignored intentionally
+
+#DEPENDS = "libgeda"
+DEPENDS = "dbus gd gtk+ tcl-native tk-native"
+
+SRC_URI = "http://geda.seul.org/dist/${P}.tar.gz"
+
+inherit autotools mime
+
+EXTRA_OECONF = "--disable-update-mime-database --disable-update-desktop-database --enable-dbus"