aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/genromfs
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-26 13:29:38 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-26 15:34:08 -0700
commit203bc975c0b1454d6cfc12b8310e3d18776b93ce (patch)
treeceb48bfa18b37cf3df1c6605d09af7dbfa199c8b /recipes/genromfs
parent91d7fb6c054ac708faf28c03230b5eb8c7b74735 (diff)
downloadopenembedded-203bc975c0b1454d6cfc12b8310e3d18776b93ce.tar.gz
genromfs: add recipes, version 0.5.2 and git
Also mark myself as the maintainer of this. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/genromfs')
-rw-r--r--recipes/genromfs/genromfs.inc22
-rw-r--r--recipes/genromfs/genromfs_0.5.2.bb7
-rw-r--r--recipes/genromfs/genromfs_git.bb8
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes/genromfs/genromfs.inc b/recipes/genromfs/genromfs.inc
new file mode 100644
index 0000000000..3f765146ec
--- /dev/null
+++ b/recipes/genromfs/genromfs.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "genromfs generates romfs filesystem images"
+HOMEPAGE = "http://jf.koan19.org/dev/romfs/"
+LICENSE = "GPLv2+"
+INC_PR = "0"
+
+EXTRA_OEMAKE = '\
+ "CC=${CC}" \
+ "LDFLAGS=${LDFLAGS}" \
+ "prefix=${prefix}" \
+ "bindir=${bindir}" \
+ "mandir=${mandir}" \
+'
+
+do_compile () {
+ oe_runmake 'CFLAGS=${CFLAGS} -DVERSION=\"$(VERSION)\"'
+}
+
+do_install () {
+ oe_runmake 'PREFIX=${D}' install
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes/genromfs/genromfs_0.5.2.bb b/recipes/genromfs/genromfs_0.5.2.bb
new file mode 100644
index 0000000000..77df775500
--- /dev/null
+++ b/recipes/genromfs/genromfs_0.5.2.bb
@@ -0,0 +1,7 @@
+require genromfs.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/romfs/genromfs-0.5.2.tar.gz"
+SRC_URI[md5sum] = "2a91463c56f9e042edc330c063a0cf5a"
+SRC_URI[sha256sum] = "30f37fc734572c1dbaa2504585bc23ba6b8fd7df767ae7155995b2ca0ebed960"
diff --git a/recipes/genromfs/genromfs_git.bb b/recipes/genromfs/genromfs_git.bb
new file mode 100644
index 0000000000..3d342f5451
--- /dev/null
+++ b/recipes/genromfs/genromfs_git.bb
@@ -0,0 +1,8 @@
+require genromfs.inc
+
+SRCREV = "3b02d7a"
+PV = "0.0+git${SRCREV}"
+PR = "${INC_PR}.0"
+
+SRC_URI = "git://github.com/chexum/genromfs;protocol=git;branch=master"
+S = "${WORKDIR}/git"