aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gettext/gettext-0.17
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gettext/gettext-0.17
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gettext/gettext-0.17')
-rw-r--r--recipes/gettext/gettext-0.17/autotools.patch62
-rw-r--r--recipes/gettext/gettext-0.17/gettext-error_print_progname.patch13
-rw-r--r--recipes/gettext/gettext-0.17/use_open_properly.patch15
-rw-r--r--recipes/gettext/gettext-0.17/wchar-uclibc.patch96
4 files changed, 186 insertions, 0 deletions
diff --git a/recipes/gettext/gettext-0.17/autotools.patch b/recipes/gettext/gettext-0.17/autotools.patch
new file mode 100644
index 0000000000..9f16b1881f
--- /dev/null
+++ b/recipes/gettext/gettext-0.17/autotools.patch
@@ -0,0 +1,62 @@
+Index: gettext-0.17/gettext-runtime/man/Makefile.am
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/man/Makefile.am 2007-10-07 21:37:36.000000000 +0200
++++ gettext-0.17/gettext-runtime/man/Makefile.am 2008-05-09 22:46:37.000000000 +0200
+@@ -158,8 +158,7 @@
+ $(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
+ mv t-$@ $@
+
+-install-html-local:
+- $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+ for file in $(man_HTML); do \
+ if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+ $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+Index: gettext-0.17/gettext-tools/man/Makefile.am
+===================================================================
+--- gettext-0.17.orig/gettext-tools/man/Makefile.am 2007-10-28 00:18:37.000000000 +0200
++++ gettext-0.17/gettext-tools/man/Makefile.am 2008-05-09 22:46:37.000000000 +0200
+@@ -186,8 +186,7 @@
+ $(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
+ mv t-$@ $@
+
+-install-html-local:
+- $(mkdir_p) $(DESTDIR)$(htmldir)
++install-html: installdirs-html
+ for file in $(man_HTML); do \
+ if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+ $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
+Index: gettext-0.17/gettext-runtime/libasprintf/configure.ac
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/libasprintf/configure.ac 2008-05-09 22:53:42.000000000 +0200
++++ gettext-0.17/gettext-runtime/libasprintf/configure.ac 2008-05-09 22:53:54.000000000 +0200
+@@ -1,5 +1,5 @@
+ dnl Configuration for the GNU libasprintf library
+-dnl Copyright (C) 2002-2006 Free Software Foundation, Inc.
++dnl Copyright (C) 2002-2007 Free Software Foundation, Inc.
+ dnl
+ dnl This program is free software: you can redistribute it and/or modify
+ dnl it under the terms of the GNU General Public License as published by
+@@ -54,8 +54,7 @@
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_INLINE
+ AC_TYPE_SIZE_T
+-gl_AC_TYPE_LONG_LONG
+-gt_TYPE_LONGDOUBLE
++AC_TYPE_LONG_LONG_INT
+ gt_TYPE_WCHAR_T
+ gt_TYPE_WINT_T
+ AC_CHECK_TYPE([ptrdiff_t], ,
+@@ -79,8 +78,11 @@
+ AC_SUBST([ALLOCA_H])
+
+ AC_CHECK_FUNCS([snprintf vasprintf wcslen])
+-AC_CHECK_DECLS([_snprintf])
++dnl Use the _snprintf function only if it is declared (because on NetBSD it
++dnl is defined as a weak alias of snprintf; we prefer to use the latter).
++AC_CHECK_DECLS([_snprintf], , , [#include <stdio.h>])
+ gt_PRINTF_POSIX
++gl_EOVERFLOW
+
+ dnl Check for tools needed for formatting the documentation.
+ ac_aux_dir_abs=`cd $ac_aux_dir && pwd`
diff --git a/recipes/gettext/gettext-0.17/gettext-error_print_progname.patch b/recipes/gettext/gettext-0.17/gettext-error_print_progname.patch
new file mode 100644
index 0000000000..0f67cd0b2e
--- /dev/null
+++ b/recipes/gettext/gettext-0.17/gettext-error_print_progname.patch
@@ -0,0 +1,13 @@
+Index: gettext-0.17/gettext-tools/libgettextpo/error.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/libgettextpo/error.h 2008-07-27 21:16:25.561115527 +0200
++++ gettext-0.17/gettext-tools/libgettextpo/error.h 2008-07-27 21:16:52.454440505 +0200
+@@ -49,7 +49,7 @@
+ /* If NULL, error will flush stdout, then print on stderr the program
+ name, a colon and a space. Otherwise, error will call this
+ function without parameters instead. */
+-extern DLL_VARIABLE void (*error_print_progname) (void);
++void (*error_print_progname) (void);
+
+ /* This variable is incremented each time `error' is called. */
+ extern DLL_VARIABLE unsigned int error_message_count;
diff --git a/recipes/gettext/gettext-0.17/use_open_properly.patch b/recipes/gettext/gettext-0.17/use_open_properly.patch
new file mode 100644
index 0000000000..111714b543
--- /dev/null
+++ b/recipes/gettext/gettext-0.17/use_open_properly.patch
@@ -0,0 +1,15 @@
+Index: gettext-0.17/gettext-tools/src/write-catalog.c
+===================================================================
+--- gettext-0.17.orig/gettext-tools/src/write-catalog.c 2008-10-16 15:18:16.000000000 +0200
++++ gettext-0.17/gettext-tools/src/write-catalog.c 2008-10-16 18:17:13.000000000 +0200
+@@ -220,7 +220,9 @@
+ /* Open the output file. */
+ if (!to_stdout)
+ {
+- fd = open (filename, O_WRONLY | O_CREAT);
++ fd = open (filename, O_WRONLY | O_CREAT,
++ /* 0666 in portable POSIX notation: */
++ S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH | S_IWOTH);
+ if (fd < 0)
+ {
+ const char *errno_description = strerror (errno);
diff --git a/recipes/gettext/gettext-0.17/wchar-uclibc.patch b/recipes/gettext/gettext-0.17/wchar-uclibc.patch
new file mode 100644
index 0000000000..7b3880bf77
--- /dev/null
+++ b/recipes/gettext/gettext-0.17/wchar-uclibc.patch
@@ -0,0 +1,96 @@
+Index: gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-runtime/gnulib-lib/wchar.in.h 2008-07-29 14:51:52.336394636 +0200
++++ gettext-0.17/gettext-runtime/gnulib-lib/wchar.in.h 2008-07-29 14:52:25.546430195 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+Index: gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/gnulib-lib/wchar.in.h 2008-07-29 14:52:03.886393956 +0200
++++ gettext-0.17/gettext-tools/gnulib-lib/wchar.in.h 2008-07-29 14:52:50.876388000 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif
+Index: gettext-0.17/gettext-tools/libgettextpo/wchar.in.h
+===================================================================
+--- gettext-0.17.orig/gettext-tools/libgettextpo/wchar.in.h 2008-07-29 14:51:58.826395009 +0200
++++ gettext-0.17/gettext-tools/libgettextpo/wchar.in.h 2008-07-29 14:52:38.609723575 +0200
+@@ -1,6 +1,6 @@
+ /* A substitute for ISO C99 <wchar.h>, for platforms that have issues.
+
+- Copyright (C) 2007 Free Software Foundation, Inc.
++ Copyright (C) 2007-2008 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -26,6 +26,14 @@
+ * the declaration of wcwidth().
+ */
+
++#ifdef __need_mbstate_t
++/* Special invocation convention inside uClibc header files. */
++
++#@INCLUDE_NEXT@ @NEXT_WCHAR_H@
++
++#else
++/* Normal invocation convention. */
++
+ #ifndef _GL_WCHAR_H
+
+ /* Tru64 with Desktop Toolkit C has a bug: <stdio.h> must be included before
+@@ -80,3 +88,4 @@
+
+ #endif /* _GL_WCHAR_H */
+ #endif /* _GL_WCHAR_H */
++#endif